# CVE-2026-105945: The Pulsar Packages Management Service can be configured to store packages on the local filesystem of the broker by using the filesystem storage provider.


- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-56rw-r678-mmwc, MINI-6mmx-c6v3-cwwr, MINI-cqmg-hjrc-c28m, MINI-jjwq-9755-pq7q, MINI-jv3m-m293-hxch

## What is CVE-2026-105945?

CVE-2026-105945 is a high-severity vulnerability in Apache Pulsar, published on 21 Oct 2026. 

### Official description

The Pulsar Packages Management Service can be configured to store packages on the local filesystem of the broker by using the filesystem storage provider. Package names consist of a type, tenant, namespace, name and version. Authorization of package operations is based only on the tenant and namespace, while the storage location of a package is derived from all of these components. The version component of a package name was not validated, so it could contain URL-encoded path separators and parent directory references. The filesystem storage provider resolved such a version to a location belonging to a package in a different tenant or namespace. Because that location is inside the configured storage directory, the containment check that the filesystem storage provider performs in recent releases did not prevent the access.

An authenticated user who has the packages permission on any namespace could use this to download, overwrite or delete packages stored in other tenants or namespaces for which the user has no permission. Packages overwritten or deleted in this way may be used by Pulsar Functions, Sources or Sinks, so the issue can affect the integrity and availability of these components. If authentication is disabled, the operations are available to any client that can reach the broker's admin REST API.

This issue only affects deployments in which package management is enabled with the broker setting enablePackagesManagement and the filesystem storage provider (FileSystemPackagesStorageProvider) is configured with the setting packagesManagementStorageProvider. Package management is disabled by default, and the default storage provider, which stores packages in Apache BookKeeper, is not affected.

This issue affects Apache Pulsar versions from 2.10.0 before 4.0.14 and from 4.1.0 before 4.2.5.

- 4.0.x version users should upgrade to at least 4.0.14.
- 4.1.x and 4.2.x version users should upgrade to at least 4.2.5.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

The currently supported Apache Pulsar release lines are 4.0.x and 5.0.x. The supported versions schedule is available at https://pulsar.apache.org/contribute/release-policy/.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-105945?


## How do I fix CVE-2026-105945?

Upgrade to a fixed version.

## Is CVE-2026-105945 being exploited?

There is no known exploitation of CVE-2026-105945 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105945 and fix it if it is affected.

What it is: CVE-2026-105945 is a high-severity vulnerability in Apache Pulsar, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-105945 in the wild and no public exploit code.

Affected product: Apache Pulsar. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105945/ (Markdown: https://insights.sbomify.com/CVE-2026-105945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105945
- OSV: https://osv.dev/vulnerability/CVE-2026-105945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105945/
Summaries are generated and may contain mistakes; the official description above is the record.
