# CVE-2026-106070: A flaw in the Node.js `zlib.ZipFile` API can cause it to return bytes that do not belong to the requested entry after the local and central


- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** ALPINE-CVE-2026-106070, BIT-node-2026-106070, BIT-node-min-2026-106070, GHSA-c2qw-fgxm-vxx4, UBUNTU-CVE-2026-106070

## What is CVE-2026-106070?

CVE-2026-106070 is a low-severity vulnerability in nodejs node, published on 23 Oct 2026. 

### Official description

A flaw in the Node.js `zlib.ZipFile` API can cause it to return bytes that do not belong to the requested entry after the local and central header validation fails.

When `zipEntry.modified` is read on an archive whose local header does not match its central directory, either directly or while compacting the archive, the validation error is caught but the parsed local header is left cached without a content offset. A later content read then returns attacker-controlled bytes from the start of the file instead of rejecting the archive, and CRC-32 verification still passes because the attacker controls the central directory CRC. A Node.js-based scanner can therefore approve different content from what another ZIP implementation extracts from the same archive.

This vulnerability affects Node.js **26.x**.

Weakness: CWE-840

## Which versions are affected by CVE-2026-106070?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 25.0.0 | 26.12.1 |
| `node-min` | Bitnami | From 25.0.0 | 26.12.1 |

## How do I fix CVE-2026-106070?

Upgrade node to 26.12.1 or later.

## Is CVE-2026-106070 being exploited?

There is no known exploitation of CVE-2026-106070 in the wild and no public exploit code.

Public exploit code:

- Offline Node.js evidence checker for CVE-2026-106070: ZipFile invalid-header content substitution. Single-file Python; JSON/CSV/HTML reports; no exploit payloads. (github_poc): https://github.com/CompleteTech-Security/node-cve-2026-106070-check

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106070 and fix it if it is affected.

What it is: CVE-2026-106070 is a low-severity vulnerability in nodejs node, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-106070 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 25.0.0; fixed in 26.12.1
- node-min (Bitnami): affected from 25.0.0; fixed in 26.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106070/ (Markdown: https://insights.sbomify.com/CVE-2026-106070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106070
- OSV: https://osv.dev/vulnerability/CVE-2026-106070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106070/
Summaries are generated and may contain mistakes; the official description above is the record.
