# CVE-2026-106071: A flaw in Node.js Permission Model filesystem enforcement can grant access to paths that do not match a wildcard `--allow-fs-read` or `--allow-fs-write` rule.


- **Severity:** Low 3.6 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N/CR:M/IR:M/AR:M`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** ALPINE-CVE-2026-106071, AZL-111023, BIT-node-2026-106071, BIT-node-min-2026-106071, GHSA-jjjg-m7c2-q32j, UBUNTU-CVE-2026-106071

## What is CVE-2026-106071?

CVE-2026-106071 is a low-severity vulnerability in nodejs node, published on 23 Oct 2026. 

### Official description

A flaw in Node.js Permission Model filesystem enforcement can grant access to paths that do not match a wildcard `--allow-fs-read` or `--allow-fs-write` rule.

When the requested path is shorter than the prefix of a wildcard grant, the radix tree lookup stops comparing early and treats the path as a match. For example, `--allow-fs-read=/etc/passwd.*` also allows reading `/etc/passwd`. This requires the wildcard grant to sit directly under the root of the permission tree, for example when it is the only grant for that scope. This is a different root cause from CVE-2026-58043.

This vulnerability affects Node.js **26.x**.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-106071?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 25.0.0 | 26.12.1 |
| `node-min` | Bitnami | From 25.0.0 | 26.12.1 |

## How do I fix CVE-2026-106071?

Upgrade node to 26.12.1 or later.

## Is CVE-2026-106071 being exploited?

There is no known exploitation of CVE-2026-106071 in the wild and no public exploit code.

Public exploit code:

- Offline Node.js evidence checker for CVE-2026-106071: Permission Model wildcard path over-grant. Single-file Python; JSON/CSV/HTML reports; no exploit payloads. (github_poc): https://github.com/CompleteTech-Security/node-cve-2026-106071-check

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106071 and fix it if it is affected.

What it is: CVE-2026-106071 is a low-severity vulnerability in nodejs node, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-106071 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 25.0.0; fixed in 26.12.1
- node-min (Bitnami): affected from 25.0.0; fixed in 26.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106071/ (Markdown: https://insights.sbomify.com/CVE-2026-106071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106071
- OSV: https://osv.dev/vulnerability/CVE-2026-106071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106071/
Summaries are generated and may contain mistakes; the official description above is the record.
