# CVE-2026-106100: Payload: Field-level write access bypass in Payload on MongoDB

> Authenticated users can bypass field-level write access controls to modify restricted fields in Payload CMS when using the MongoDB adapter.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-4ww4-68q3-h7g5

## What is CVE-2026-106100?

CVE-2026-106100 is a high-severity missing authorization vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-106100?

4 open source packages ship an affected version, including @payloadcms/db-mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/db-mongodb` | npm | All versions | 3.87.0 |
| `@payloadcms/db-mongodb` | npm | All versions | 3.87.0 |
| `@payloadcms/db-mongodb` | npm | From 4.0.0-canary.0 | 4.0.0-canary.20 |
| `@payloadcms/db-mongodb` | npm | From 4.0.0-canary.0 | 4.0.0-canary.20 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-106100?

Upgrade @payloadcms/db-mongodb to a fixed version for your release line: 3.87.0 or 4.0.0-canary.20.

## Is CVE-2026-106100 being exploited?

There is no known exploitation of CVE-2026-106100 in the wild and no public exploit code.

## Other vulnerabilities in payloadcms payload

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106100 and fix it if it is affected.

What it is: CVE-2026-106100 is a high-severity missing authorization vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106100 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/db-mongodb (npm): affected all versions; fixed in 3.87.0
- @payloadcms/db-mongodb (npm): affected all versions; fixed in 3.87.0
- @payloadcms/db-mongodb (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.20
- @payloadcms/db-mongodb (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106100/ (Markdown: https://insights.sbomify.com/CVE-2026-106100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106100
- OSV: https://osv.dev/vulnerability/CVE-2026-106100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106100/
Summaries are generated and may contain mistakes; the official description above is the record.
