{"answers":{"affected":"2 open source packages ship an affected version, including quasar.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106101 exists.","fix":"Upgrade quasar to 2.32.2 or later.","what":"CVE-2026-106101 is a low-severity vulnerability in quasarframework quasar, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-106101 and fix it if it is affected.\n\nWhat it is: CVE-2026-106101 is a low-severity vulnerability in quasarframework quasar, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106101 exists.\n\nAffected packages and fixed versions:\n- quasar (npm): affected all versions; fixed in 2.32.2\n- quasar (npm): affected all versions; fixed in 2.32.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-106101/ (Markdown: https://insights.sbomify.com/CVE-2026-106101/index.md)","id":"CVE-2026-106101","markdown":"https://insights.sbomify.com/CVE-2026-106101/index.md","name":"CVE-2026-106101","record":{"aliases":["GHSA-89vp-x45c-52cq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue.js UI framework","requires_auth":"none","summary":"Attackers can cause client-side denial of service in Quasar Framework by clobbering the SafariViewController object via DOM manipulation.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to 2.32.2, the openURL() utility in ui/src/utils/open-url/open-url.js trusted window.SafariViewController whenever that global existed in an iOS environment. Attacker-controlled HTML rendered by components such as QEditor can create a named SafariViewController element, causing browser named-property resolution to replace the expected native bridge object. A later openURL() call then invokes isAvailable() on the element, throws a TypeError, and disrupts external navigation, login redirects, payment redirects, and other URL-opening workflows. QSelect and QChatMessage HTML-rendering configurations can expose the same trigger when they render attacker-controlled HTML. This issue is fixed in version 2.32.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Quasar Framework: DOM Clobbering in Quasar openURL() SafariViewController Integration Causes Client-Side Denial of Service","id":"CVE-2026-106101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Quasar Framework: Stored/Reflected XSS via unescaped SSR meta tag rendering in getHead()","id":"CVE-2026-106102"},"packages":[{"ecosystem":"npm","fixed":["2.32.2"],"introduced":["0"],"last_affected":[],"package":"quasar","purl":null,"source":"GHSA-89vp-x45c-52cq"},{"ecosystem":"npm","fixed":["2.32.2"],"introduced":["0"],"last_affected":[],"package":"quasar","purl":"pkg:npm/quasar","source":"GHSA-89vp-x45c-52cq"}],"prev":{"headline":"Payload: Field-level write access bypass in Payload on MongoDB","id":"CVE-2026-106100"},"products":["quasar"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["quasarframework"]},"summary":"Attackers can cause client-side denial of service in Quasar Framework by clobbering the SafariViewController object via DOM manipulation.","url":"https://insights.sbomify.com/CVE-2026-106101/"}