# CVE-2026-106105: Quasar Framework: Development TLS private keys are cached with overly permissive filesystem permissions

> Local attackers can read cached TLS private keys due to permissive file permissions, allowing them to impersonate development endpoints.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-fh39-c73x-5pjv

## What is CVE-2026-106105?

CVE-2026-106105 is a high-severity vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to @quasar/ssl-certificate 2.1.0, @quasar/cli 5.0.4, and @quasar/app-vite 3.3.0, the @quasar/ssl-certificate utility cached a combined private key and certificate PEM without explicitly applying owner-only filesystem permissions. Another local user able to read the cache can copy the key and impersonate a development TLS endpoint in an environment that trusts the certificate. The generated certificate was also CA-capable, carried unnecessarily broad key usages, and encoded the IPv6 loopback address as a DNS subject alternative name. This issue is fixed in @quasar/ssl-certificate 2.1.0, @quasar/cli 5.0.4, and @quasar/app-vite 3.3.0.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-106105?

6 open source packages ship an affected version, including @quasar/app-vite, @quasar/cli and @quasar/ssl-certificate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |
| `@quasar/cli` | npm | All versions | 5.0.4 |
| `@quasar/cli` | npm | All versions | 5.0.4 |
| `@quasar/ssl-certificate` | npm | All versions | 2.1.0 |
| `@quasar/ssl-certificate` | npm | All versions | 2.1.0 |

## How do I fix CVE-2026-106105?

Upgrade @quasar/app-vite to 3.3.0 or later.

## Is CVE-2026-106105 being exploited?

There is no known exploitation of CVE-2026-106105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106105 and fix it if it is affected.

What it is: CVE-2026-106105 is a high-severity vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106105 in the wild and no public exploit code.

Affected packages and fixed versions:
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0
- @quasar/cli (npm): affected all versions; fixed in 5.0.4
- @quasar/cli (npm): affected all versions; fixed in 5.0.4
- @quasar/ssl-certificate (npm): affected all versions; fixed in 2.1.0
- @quasar/ssl-certificate (npm): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106105/ (Markdown: https://insights.sbomify.com/CVE-2026-106105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106105
- OSV: https://osv.dev/vulnerability/CVE-2026-106105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106105/
Summaries are generated and may contain mistakes; the official description above is the record.
