CVE-2026-106106 Quasar Framework: SSR/SSG dev error page discloses the full shell environment and its </script> escape is bypassable

High 7.1 Published Updated

Attackers can read shell environment secrets and inject scripts via SSR error pages in Quasar development servers, exposing sensitive data and enabling code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-106106?

CVE-2026-106106 is a high-severity vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0, renderSSRError() in utils/render-ssr-error/src/index.js used diagnostic data from utils/render-ssr-error/src/env.js to serialize process.env, request headers, and cookies into the HTTP page returned by serve.devError(), while the development server listened on all interfaces by default. Any network-adjacent client that reaches an SSR or SSG render failure through this development-only error path can obtain shell environment secrets. The renderer escaped only one exact lowercase script closing-tag spelling, so case variants and valid closing-tag delimiter variants in reflected diagnostic data could terminate the script element and inject markup; executing the injected code in a developer browser additionally requires the payload to accompany that developer's request. This issue is fixed in @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0.

Weakness: CWE-79, CWE-497

Which versions are affected by CVE-2026-106106?

4 open source packages ship an affected version, including @quasar/app-vite and @quasar/render-ssr-error.

PackageAffectedFixed in
@quasar/app-vite npmAll versions3.3.0
@quasar/app-vite npmAll versions3.3.0
@quasar/render-ssr-error npmAll versions2.2.4
@quasar/render-ssr-error npmAll versions2.2.4

How do I fix CVE-2026-106106?

Upgrade @quasar/app-vite to 3.3.0 or later.

Is CVE-2026-106106 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106106 exists.

Sources

Also known as GHSA-r5mf-4r5x-q78f.

Is CVE-2026-106106 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free