# CVE-2026-106106: Quasar Framework: SSR/SSG dev error page discloses the full shell environment and its </script> escape is bypassable

> Attackers can read shell environment secrets and inject scripts via SSR error pages in Quasar development servers, exposing sensitive data and enabling code execution.

- **Severity:** High 7.1 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:H/VI:L/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-r5mf-4r5x-q78f

## What is CVE-2026-106106?

CVE-2026-106106 is a high-severity vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0, renderSSRError() in utils/render-ssr-error/src/index.js used diagnostic data from utils/render-ssr-error/src/env.js to serialize process.env, request headers, and cookies into the HTTP page returned by serve.devError(), while the development server listened on all interfaces by default. Any network-adjacent client that reaches an SSR or SSG render failure through this development-only error path can obtain shell environment secrets. The renderer escaped only one exact lowercase script closing-tag spelling, so case variants and valid closing-tag delimiter variants in reflected diagnostic data could terminate the script element and inject markup; executing the injected code in a developer browser additionally requires the payload to accompany that developer's request. This issue is fixed in @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2026-106106?

4 open source packages ship an affected version, including @quasar/app-vite and @quasar/render-ssr-error.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |
| `@quasar/render-ssr-error` | npm | All versions | 2.2.4 |
| `@quasar/render-ssr-error` | npm | All versions | 2.2.4 |

## How do I fix CVE-2026-106106?

Upgrade @quasar/app-vite to 3.3.0 or later.

## Is CVE-2026-106106 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106106 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106106 and fix it if it is affected.

What it is: CVE-2026-106106 is a high-severity vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106106 exists.

Affected packages and fixed versions:
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0
- @quasar/render-ssr-error (npm): affected all versions; fixed in 2.2.4
- @quasar/render-ssr-error (npm): affected all versions; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106106/ (Markdown: https://insights.sbomify.com/CVE-2026-106106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106106
- OSV: https://osv.dev/vulnerability/CVE-2026-106106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106106/
Summaries are generated and may contain mistakes; the official description above is the record.
