# CVE-2026-106107: Quasar Framework: App Vite SSR and SSG nonce attributes are not safely constrained

> Attackers can inject malicious HTML attributes into SSR/SSG output if the nonce value is attacker-controlled, leading to XSS.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-5m6h-8g35-p3m7

## What is CVE-2026-106107?

CVE-2026-106107 is a high-severity cross-site scripting vulnerability in @quasar app-vite, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to 3.3.0, several @quasar/app-vite SSR and SSG rendering paths interpolated ssrContext.nonce directly into quoted HTML attributes. An application that derives or overrides this value with attacker-controlled data can allow a quote to terminate the nonce attribute and inject additional attributes or markup into generated HTML across development and production SSR or SSG output. Cryptographically generated base64 or base64url nonces are not affected because they lack HTML attribute delimiters. This issue is fixed in version 3.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-106107?

2 open source packages ship an affected version, including @quasar/app-vite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |
| `@quasar/app-vite` | npm | All versions | 3.3.0 |

## How do I fix CVE-2026-106107?

Upgrade @quasar/app-vite to 3.3.0 or later.

## Is CVE-2026-106107 being exploited?

There is no known exploitation of CVE-2026-106107 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106107 and fix it if it is affected.

What it is: CVE-2026-106107 is a high-severity cross-site scripting vulnerability in @quasar app-vite, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106107 in the wild and no public exploit code.

Affected packages and fixed versions:
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0
- @quasar/app-vite (npm): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106107/ (Markdown: https://insights.sbomify.com/CVE-2026-106107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106107
- OSV: https://osv.dev/vulnerability/CVE-2026-106107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106107/
Summaries are generated and may contain mistakes; the official description above is the record.
