# CVE-2026-106108: Quasar Framework: App Vite SSG page output paths can escape the configured distribution directory

> Attackers can write files outside the build directory if SSG page definitions are derived from untrusted content, requiring a build process that trusts external inputs.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-vhhq-m2gm-rwc9

## What is CVE-2026-106108?

CVE-2026-106108 is a medium-severity path traversal vulnerability in @quasar app-vite, published on 13 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. From 3.1.0 until 3.3.0, @quasar/app-vite SSG page definitions returned by getSsgPages() could supply dir and filename values that were joined to build.distDir without verifying the final destination. Parent traversal or an existing symlink below the distribution directory could create new HTML files or directories outside the output tree with the build user's permissions. Application configuration and SSG page definitions are trusted by default, so exploitation requires a build process that derives them from external or otherwise less-trusted content; existing files remain protected by the renderer's no-overwrite behavior. This issue is fixed in version 3.3.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106108?

2 open source packages ship an affected version, including @quasar/app-vite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/app-vite` | npm | From 3.1.0 | 3.3.0 |
| `@quasar/app-vite` | npm | From 3.1.0 | 3.3.0 |

## How do I fix CVE-2026-106108?

Upgrade @quasar/app-vite to 3.3.0 or later.

## Is CVE-2026-106108 being exploited?

There is no known exploitation of CVE-2026-106108 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106108 and fix it if it is affected.

What it is: CVE-2026-106108 is a medium-severity path traversal vulnerability in @quasar app-vite, published on 13 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-106108 in the wild and no public exploit code.

Affected packages and fixed versions:
- @quasar/app-vite (npm): affected from 3.1.0; fixed in 3.3.0
- @quasar/app-vite (npm): affected from 3.1.0; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106108/ (Markdown: https://insights.sbomify.com/CVE-2026-106108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106108
- OSV: https://osv.dev/vulnerability/CVE-2026-106108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106108/
Summaries are generated and may contain mistakes; the official description above is the record.
