# CVE-2026-106109: Quasar Framework: App Vite build cleanup can recursively remove unsafe configured output directories

> Attackers with build configuration control can delete arbitrary files by specifying unsafe output directories during the Vite build process.

- **Severity:** Medium 4.1 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-q9mq-245r-4g93

## What is CVE-2026-106109?

CVE-2026-106109 is a medium-severity path traversal vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. From 1.0.0 until 3.3.0, @quasar/app-vite recursively removed the resolved build.distDir before building without rejecting the project root, user home directory, filesystem roots, or symlink-resolved external directories. An unsafe trusted configuration can delete data writable by the build user before compilation begins. No attacker-controlled input reaches build.distDir by default, so exploitation requires compromised or less-trusted automation to influence build configuration, or a developer to run a mistaken configuration. This issue is fixed in version 3.3.0.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106109?

2 open source packages ship an affected version, including @quasar/app-vite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/app-vite` | npm | From 1.0.0 | 3.3.0 |
| `@quasar/app-vite` | npm | From 1.0.0 | 3.3.0 |

## How do I fix CVE-2026-106109?

Upgrade @quasar/app-vite to 3.3.0 or later.

## Is CVE-2026-106109 being exploited?

There is no known exploitation of CVE-2026-106109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106109 and fix it if it is affected.

What it is: CVE-2026-106109 is a medium-severity path traversal vulnerability in @quasar app-vite, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-106109 in the wild and no public exploit code.

Affected packages and fixed versions:
- @quasar/app-vite (npm): affected from 1.0.0; fixed in 3.3.0
- @quasar/app-vite (npm): affected from 1.0.0; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106109/ (Markdown: https://insights.sbomify.com/CVE-2026-106109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106109
- OSV: https://osv.dev/vulnerability/CVE-2026-106109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106109/
Summaries are generated and may contain mistakes; the official description above is the record.
