# CVE-2026-106121: RabbitMQ: JSONReader in the default JSON-RPC mapper never terminates on truncated input, causing DoS

> A truncated JSON input in the RabbitMQ Java client causes infinite loops or heap exhaustion, leading to denial of service.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** CLEANSTART-2026-DZ14042, CLEANSTART-2026-HP65010, CLEANSTART-2026-VT81725, DEBIAN-CVE-2026-106121, ECHO-8457-14d3-7547, GHSA-cqgh-8p3p-mx4m, MINI-278c-8qv6-4h42, MINI-4f4f-7hjm-j6xw, MINI-58qw-v4xq-836c, MINI-5wr7-4qj7-7c8m, MINI-6pm8-488g-cg9f, MINI-9mfv-w9mj-rvfv, MINI-frvq-6jr3-w7jr, MINI-hxx4-4rwq-f43f, MINI-j2xq-6q3v-5qmg, MINI-pwpr-p94c-f2c2, MINI-wqjw-gmhg-hmvj, UBUNTU-CVE-2026-106121

## What is CVE-2026-106121?

CVE-2026-106121 is a medium-severity denial of service vulnerability in com.rabbitmq amqp-client, published on 6 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.37.0, com.rabbitmq.tools.json.JSONReader.read() fails to terminate when input ends inside a quoted string or a line comment because its string and whitespace scanners do not stop at CharacterIterator.DONE. The default DefaultJsonRpcMapper passes JSON-RPC message bodies to this parser for JsonRpcServer and client replies. A truncated string causes the parser to append replacement end markers until heap exhaustion, while a line comment without a terminating newline can keep a thread consuming CPU indefinitely, resulting in denial of service. This issue is fixed in version 5.37.0.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-106121?

2 open source packages ship an affected version, including com.rabbitmq:amqp-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.36.1 |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.36.1 |

Products: Vmware Rabbitmq Java Client.

## How do I fix CVE-2026-106121?

Upgrade com.rabbitmq:amqp-client to 5.36.1 or later.

## Is CVE-2026-106121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106121 exists.

## Other vulnerabilities in com.rabbitmq amqp-client

- [CVE-2026-106122](https://insights.sbomify.com/CVE-2026-106122/): RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers (medium 6.0)
- [CVE-2026-106123](https://insights.sbomify.com/CVE-2026-106123/): RabbitMQ Java client: plaintext broker credentials leaked in exception message from ConnectionFactoryConfigurator.load() (medium 5.7)
- [CVE-2023-46120](https://insights.sbomify.com/CVE-2023-46120/): RabbitMQ Java client's lack of message size limitation leads to remote DoS attack (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106121 and fix it if it is affected.

What it is: CVE-2026-106121 is a medium-severity denial of service vulnerability in com.rabbitmq amqp-client, published on 6 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106121 exists.

Affected packages and fixed versions:
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.36.1
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.36.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106121/ (Markdown: https://insights.sbomify.com/CVE-2026-106121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106121
- OSV: https://osv.dev/vulnerability/CVE-2026-106121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106121/
Summaries are generated and may contain mistakes; the official description above is the record.
