# CVE-2026-106122: RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers

> An attacker can permanently disable RPC consumers in RabbitMQ Java client applications by sending malformed UTF-8 properties, causing unchecked exceptions and message requeuing.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** CLEANSTART-2026-JZ50665, CLEANSTART-2026-MV69619, CLEANSTART-2026-TG95490, DEBIAN-CVE-2026-106122, ECHO-4250-102d-5acc, GHSA-7822-rcf6-97fx, MINI-4w56-q26x-8pr3, MINI-c83v-3xhr-q747, MINI-g385-wmvm-g5w9, MINI-h955-jx77-7f44, MINI-hjg9-p62m-6m89, MINI-j6q4-5635-rmw5, MINI-pj67-jjfp-c728, MINI-q4fv-59pc-wphg, MINI-qx8j-wmjx-9ch7, MINI-rv5v-2wf7-wx84, MINI-vccp-7mr3-v5f3, UBUNTU-CVE-2026-106122

## What is CVE-2026-106122?

CVE-2026-106122 is a medium-severity denial of service vulnerability in com.rabbitmq amqp-client, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.36.0, ValueReader.readShortstr decodes malformed UTF-8 bytes into replacement characters that can re-encode beyond the AMQP shortstr limit enforced by ValueWriter.writeShortstr. An attacker who can submit an RPC message with a malformed echoed property can cause reply publication in RpcServer.mainloop() or tutorial-style consumers to throw an unchecked exception before acknowledgement. The broker requeues the message, allowing the same message to disable replacement consumers until the queue is purged. This issue is fixed in version 5.36.0.

Weakness: CWE-248 (Uncaught Exception), CWE-172 (Improper Encoding or Decoding of Data)

## Which versions are affected by CVE-2026-106122?

2 open source packages ship an affected version, including com.rabbitmq:amqp-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.36.0 |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.36.0 |

Products: Vmware Rabbitmq Java Client.

## How do I fix CVE-2026-106122?

Upgrade com.rabbitmq:amqp-client to 5.36.0 or later.

## Is CVE-2026-106122 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106122 exists.

## Other vulnerabilities in com.rabbitmq amqp-client

- [CVE-2026-106123](https://insights.sbomify.com/CVE-2026-106123/): RabbitMQ Java client: plaintext broker credentials leaked in exception message from ConnectionFactoryConfigurator.load() (medium 5.7)
- [CVE-2026-106121](https://insights.sbomify.com/CVE-2026-106121/): RabbitMQ: JSONReader in the default JSON-RPC mapper never terminates on truncated input, causing DoS (medium 4.9)
- [CVE-2023-46120](https://insights.sbomify.com/CVE-2023-46120/): RabbitMQ Java client's lack of message size limitation leads to remote DoS attack (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106122 and fix it if it is affected.

What it is: CVE-2026-106122 is a medium-severity denial of service vulnerability in com.rabbitmq amqp-client, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-106122 exists.

Affected packages and fixed versions:
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.36.0
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.36.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106122/ (Markdown: https://insights.sbomify.com/CVE-2026-106122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106122
- OSV: https://osv.dev/vulnerability/CVE-2026-106122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106122/
Summaries are generated and may contain mistakes; the official description above is the record.
