# CVE-2026-106435: Application denial of service via out-of-bounds read in BSON Regex decoding in MongoDB Python Driver

> An attacker supplying malformed BSON to the MongoDB Python Driver's decode API can cause a denial of service via out-of-bounds read when the C extension is loaded.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** AZL-107129, DEBIAN-CVE-2026-106435, ECHO-0def-1f54-e1ea, GHSA-98qm-wvgf-w4cf, MINI-8jph-pcjp-cf84, UBUNTU-CVE-2026-106435

## What is CVE-2026-106435?

CVE-2026-106435 is a medium-severity denial of service vulnerability in MongoDB Python Driver, published on 8 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The MongoDB Python Driver's binary accelerator can read outside a buffer when an application decodes malformed BSON containing a truncated regular-expression element without a trailing NUL byte. An actor who can supply BSON to the documented decode or decode_all API can cause the application process to terminate when the C extension is loaded. The driver's normal database wire-protocol path does not reach this code.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-106435?

2 open source packages ship an affected version, including pymongo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pymongo` | PyPI | From 3.9.0 | 4.18.3 |
| `pymongo` | PyPI | From 3.9.0 | 4.18.3 |

Products: Mongodb Python Driver.

## How do I fix CVE-2026-106435?

Upgrade pymongo to 4.18.3 or later.

## Is CVE-2026-106435 being exploited?

There is no known exploitation of CVE-2026-106435 in the wild and no public exploit code.

## Other vulnerabilities in MongoDB Python Driver

- [CVE-2026-88029](https://insights.sbomify.com/CVE-2026-88029/): GridFS data disclosure and deletion via query-operator injection in file IDs in the MongoDB Python Driver (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106435 and fix it if it is affected.

What it is: CVE-2026-106435 is a medium-severity denial of service vulnerability in MongoDB Python Driver, published on 8 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106435 in the wild and no public exploit code.

Affected packages and fixed versions:
- pymongo (PyPI): affected from 3.9.0; fixed in 4.18.3
- pymongo (PyPI): affected from 3.9.0; fixed in 4.18.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106435/ (Markdown: https://insights.sbomify.com/CVE-2026-106435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106435
- OSV: https://osv.dev/vulnerability/CVE-2026-106435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106435/
Summaries are generated and may contain mistakes; the official description above is the record.
