{"answers":{"affected":"3 open source packages ship an affected version, including weasyprint and WeasyPrint.","exploited":"There is no known exploitation of CVE-2026-106443 in the wild and no public exploit code.","fix":"Upgrade weasyprint to 70.0 or later.","what":"CVE-2026-106443 is a high-severity code injection vulnerability in Kozea WeasyPrint, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-106443 and fix it if it is affected.\n\nWhat it is: CVE-2026-106443 is a high-severity code injection vulnerability in Kozea WeasyPrint, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-106443 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- weasyprint (PyPI): affected all versions; fixed in 70.0\n- weasyprint (PyPI): affected all versions; fixed in 70.0\n- WeasyPrint (PyPI): affected all versions; fixed in 70.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-106443/ (Markdown: https://insights.sbomify.com/CVE-2026-106443/index.md)","id":"CVE-2026-106443","markdown":"https://insights.sbomify.com/CVE-2026-106443/index.md","name":"CVE-2026-106443","record":{"aliases":["DEBIAN-CVE-2026-106443","GHSA-r543-q48m-4c9j","PYSEC-2026-4311","UBUNTU-CVE-2026-106443"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python PDF library","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by supplying malicious EPS images to WeasyPrint if Ghostscript is installed on the host.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue is fixed in version 70.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE","id":"CVE-2026-106443","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Handlebars: JavaScript Injection via Unsafe Inline Embedding of Precompiled Templates","id":"CVE-2026-106444"},"packages":[{"ecosystem":"PyPI","fixed":["70.0"],"introduced":["0"],"last_affected":[],"package":"WeasyPrint","purl":null,"source":"GHSA-r543-q48m-4c9j"},{"ecosystem":"PyPI","fixed":["70.0"],"introduced":["0"],"last_affected":[],"package":"weasyprint","purl":"pkg:pypi/weasyprint","source":"GHSA-r543-q48m-4c9j"},{"ecosystem":"PyPI","fixed":["70.0"],"introduced":["0"],"last_affected":[],"package":"weasyprint","purl":"pkg:pypi/weasyprint","source":"PYSEC-2026-4311"}],"prev":{"headline":"Hydra instantiate target blacklist bypasses permit code execution","id":"CVE-2026-106442"},"products":["WeasyPrint"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["Kozea"]},"summary":"Attackers can achieve remote code execution by supplying malicious EPS images to WeasyPrint if Ghostscript is installed on the host.","url":"https://insights.sbomify.com/CVE-2026-106443/"}