# CVE-2026-106449: yawkat LZ4 Java: LZ4BlockInputStream with stopOnEmptyBlock=false recurses once per empty block, causing StackOverflowError

> An attacker can cause a denial of service via stack exhaustion in the LZ4 Java library when configured to process empty blocks recursively.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2026-AB78638, CLEANSTART-2026-BO87876, CLEANSTART-2026-EA15585, CLEANSTART-2026-GW69718, CLEANSTART-2026-MS32897, CLEANSTART-2026-WC49025, CLEANSTART-2026-YW37682, DEBIAN-CVE-2026-106449, ECHO-df47-6feb-99c5, GHSA-343h-94h5-c4wr, MINI-2vcg-65cm-2jv3, MINI-3ccp-3wvc-v4wg, MINI-3ghp-7qrr-5m4g, MINI-3q42-7x3g-9qfm, MINI-3rx6-j7mp-4qw9, MINI-4cgp-4fx7-696j, MINI-5gp6-rmhq-gfc8, MINI-5m54-g95g-cr87, MINI-5mq7-hw2f-vjw7, MINI-5w2q-rm44-p627, MINI-62f9-37j5-jc7g, MINI-6cf7-68wr-9997, MINI-7ccr-m99p-2w6g, MINI-8c83-pc9v-6rwv, MINI-ff2m-7cf9-xvh5, MINI-fxpm-w63j-jqf8, MINI-grj5-4hmh-xcgx, MINI-h5rq-h3r7-867g, MINI-h94r-q6vr-78vj, MINI-jjgj-jjm4-847v, MINI-jqjj-5ppp-7r5w, MINI-m47c-xrvm-3hg4, MINI-ph42-2j38-qmjv, MINI-phgm-rm4g-phjg, MINI-qf75-c34r-3p7w, MINI-qpfp-vmr4-56jf, MINI-qq5q-xf24-fvpm, MINI-qqrg-vfr4-fmg9, MINI-qv64-f9jh-6p85, MINI-rmm8-x9xm-7qmc, MINI-rr56-99jr-jwgh, MINI-rv84-w7rf-4m38, MINI-v44w-94q6-2rjv, MINI-vhqq-3ww2-q576, MINI-vvgq-7wpw-h4wv, MINI-wrm4-q8xq-78mc, MINI-x6rx-597g-xvg9, MINI-xph8-h442-7jj3, UBUNTU-CVE-2026-106449

## What is CVE-2026-106449?

CVE-2026-106449 is a low-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.4, net.jpountz.lz4.LZ4BlockInputStream configured with stopOnEmptyBlock set to false handles each well-formed empty LZ4Block by recursively calling refill(), allowing a long sequence of empty blocks in an attacker-controlled compressed stream to exhaust the decoding thread's stack and throw StackOverflowError. The default stopOnEmptyBlock setting is true and is not affected, and the issue does not cause memory corruption. This issue is fixed in version 1.11.4.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-106449?

4 open source packages ship an affected version, including at.yawk.lz4:lz4-java and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.4 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.4 |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |

## How do I fix CVE-2026-106449?

Upgrade at.yawk.lz4:lz4-java to 1.11.4 or later.

## Is CVE-2026-106449 being exploited?

There is no known exploitation of CVE-2026-106449 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106449 and fix it if it is affected.

What it is: CVE-2026-106449 is a low-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106449 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.4
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.4
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106449/ (Markdown: https://insights.sbomify.com/CVE-2026-106449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106449
- OSV: https://osv.dev/vulnerability/CVE-2026-106449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106449/
Summaries are generated and may contain mistakes; the official description above is the record.
