# CVE-2026-106451: yawkat LZ4 Java: Native library extraction to a shared temporary directory is vulnerable to file replacement by another local user

> A local attacker can exploit a race condition in native library extraction to replace the library file, potentially executing arbitrary code as the victim.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2026-IA44862, CLEANSTART-2026-KU71354, CLEANSTART-2026-OZ05879, CLEANSTART-2026-TX68944, CLEANSTART-2026-WI71078, CLEANSTART-2026-XP90287, CLEANSTART-2026-YP08378, DEBIAN-CVE-2026-106451, ECHO-6344-f98f-134d, GHSA-mcr4-qmvw-px4g, MINI-24v7-jj9f-9gqr, MINI-2r7g-3c2v-q5mc, MINI-344r-9q57-856j, MINI-3gcf-692j-wh68, MINI-3pgf-49qx-86wr, MINI-48g2-hfwc-pwfv, MINI-4r67-57mq-vpjv, MINI-5f7x-pw74-c569, MINI-6gh2-8gvq-mw26, MINI-7m69-532p-9c23, MINI-7w33-cmqj-95xg, MINI-827v-7464-86gv, MINI-8ghp-r6qp-rwp4, MINI-c98g-qp9w-jxcw, MINI-f7fm-rr75-m9vg, MINI-fcfw-q574-hwgh, MINI-g429-w4c5-vw3q, MINI-gffw-6x8m-55jp, MINI-h2wx-c26q-v7gf, MINI-hhfw-h8x9-vr6q, MINI-hxw3-r947-4h84, MINI-j8v8-vgf5-8jwf, MINI-jrvj-c9hg-xq7p, MINI-m3xj-j7mg-5hc6, MINI-m8gc-2w5g-w89p, MINI-mv84-286f-j578, MINI-pw22-wjr3-jhj9, MINI-px8q-543q-jp3j, MINI-qh27-g577-vh3h, MINI-r3f7-vp88-rqqc, MINI-rf66-qx83-98fx, MINI-rqmh-w62v-xfgg, MINI-rrg5-pjgf-jqj5, MINI-rxpp-895f-56vg, MINI-v5wv-7rvh-2988, MINI-v8p4-42rg-2jpj, MINI-vc6q-xrh8-93jj, MINI-x96w-hw6g-fw7v, ROOT-APP-MAVEN-CVE-2026-106451, UBUNTU-CVE-2026-106451

## What is CVE-2026-106451?

CVE-2026-106451 is a high-severity vulnerability in yawkat lz4-java, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. From 1.7.0 until 1.11.4, net.jpountz.util.Native.load() uses File.createTempFile to create an exclusive temporary .lck file but derives the native-library path by removing the suffix, then FileOutputStream opens that predictable path without exclusive creation, allowing another local user with access to the same shared temporary directory to create or replace the library file before System.load() uses it. Successful exploitation depends on shared-directory permissions, host protections, and winning the race, and can execute native code as the victim; hardened systems may instead cause library loading to fail and fall back to Java implementations. Configurations using a system library, a private java.io.tmpdir, or Java-only implementations are not affected. This issue is fixed in version 1.11.4.

Weakness: CWE-377 (DEPRECATED: Insecure Temporary File), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-106451?

4 open source packages ship an affected version, including at.yawk.lz4:lz4-java and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.4 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.4 |
| `org.lz4:lz4-java` | Maven | From 1.7.0 to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | From 1.7.0 to 1.8.1 | None |

## How do I fix CVE-2026-106451?

Upgrade at.yawk.lz4:lz4-java to 1.11.4 or later.

## Is CVE-2026-106451 being exploited?

There is no known exploitation of CVE-2026-106451 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106451 and fix it if it is affected.

What it is: CVE-2026-106451 is a high-severity vulnerability in yawkat lz4-java, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106451 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.4
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.4
- org.lz4:lz4-java (Maven): affected from 1.7.0 up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected from 1.7.0 up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106451/ (Markdown: https://insights.sbomify.com/CVE-2026-106451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106451
- OSV: https://osv.dev/vulnerability/CVE-2026-106451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106451/
Summaries are generated and may contain mistakes; the official description above is the record.
