# CVE-2026-106452: yawkat LZ4 Java: LZ4BlockInputStream allocates an unvalidated compressed length from the stream header

> An attacker can cause a denial of service by sending a crafted LZ4 stream that triggers excessive memory allocation in the Java library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2026-CX61220, CLEANSTART-2026-ER27967, CLEANSTART-2026-GT24966, CLEANSTART-2026-HV49575, CLEANSTART-2026-HX04785, CLEANSTART-2026-OM13528, DEBIAN-CVE-2026-106452, ECHO-0e98-3ae9-088f, GHSA-4v53-57pg-c464, MINI-2273-48mc-2xvc, MINI-242v-42j2-v6cm, MINI-24j6-8jg2-38p9, MINI-292p-mhpp-f3mf, MINI-2ch4-4g48-89v5, MINI-2jxr-7cv8-rxvm, MINI-3x7v-8g6v-jx3g, MINI-3xr2-x7w3-4xgp, MINI-5m2g-cc88-hgf4, MINI-7729-g5xj-mgwh, MINI-7h9q-78p7-rh7j, MINI-8fjq-v28j-56vm, MINI-8qrj-82wm-q7f5, MINI-8wvq-h9qp-6x3h, MINI-9j4p-5m29-jgm8, MINI-c6xg-g8vg-5rx6, MINI-chpc-jqqh-69hw, MINI-cx9q-j7jm-7rc3, MINI-f87w-rjfm-5x4f, MINI-fh8q-wr6x-wf5w, MINI-fmr2-6hwg-h4rg, MINI-gcc7-8jwc-pw5j, MINI-gmv3-x2x3-v4fg, MINI-h6vq-j9j2-mc4j, MINI-hghr-x355-qmp7, MINI-hgpf-vcxq-6mmx, MINI-j754-hfmx-hv7v, MINI-jm38-xfg8-329h, MINI-mcqg-h5gr-x9vj, MINI-mg3g-xcq2-8crp, MINI-pgm4-j22h-3jqp, MINI-q859-gq73-rm55, MINI-qvcv-2pp9-fp3h, MINI-r36v-g5px-4q5x, MINI-rjx8-qmf8-89fx, MINI-rv87-g4hh-cx9c, MINI-v5wx-v9vj-7p8p, MINI-w2wj-cjqh-546q, MINI-w33m-c2gw-57c2, MINI-w42m-6rp5-rjhw, MINI-w5qg-f5hg-g7fg, MINI-w9f5-634q-ppg5, MINI-wm6w-r2v7-gv47, MINI-wx5c-mxff-hw9c, MINI-x95v-422j-46x6, MINI-xh9j-c3x5-fpp2, UBUNTU-CVE-2026-106452

## What is CVE-2026-106452?

CVE-2026-106452 is a medium-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.2, net.jpountz.lz4.LZ4BlockInputStream refill() validates that the compressedLen field in a legacy LZ4Block header is nonnegative but allocates a compressed-input buffer of that attacker-controlled size before reading payload data, allowing a header-only stream to request a near-2 GiB allocation and exhaust the JVM heap. Canonical writers emit raw blocks when compression is not smaller than the original block, but vulnerable readers accept non-canonical oversized compressed blocks. This issue is fixed in version 1.11.2.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-106452?

4 open source packages ship an affected version, including at.yawk.lz4:lz4-java and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.2 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.2 |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |

## How do I fix CVE-2026-106452?

Upgrade at.yawk.lz4:lz4-java to 1.11.2 or later.

## Is CVE-2026-106452 being exploited?

There is no known exploitation of CVE-2026-106452 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106452 and fix it if it is affected.

What it is: CVE-2026-106452 is a medium-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106452 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.2
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.2
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106452/ (Markdown: https://insights.sbomify.com/CVE-2026-106452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106452
- OSV: https://osv.dev/vulnerability/CVE-2026-106452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106452/
Summaries are generated and may contain mistakes; the official description above is the record.
