# CVE-2026-106453: yawkat LZ4 Java: LZ4DecompressorWithLength allocates the unvalidated size from the 4-byte length header, so a 5-byte input triggers a 1 GiB allocation and OutOfMemoryError

> Attackers can cause a denial of service by sending small inputs that trigger excessive memory allocation in the LZ4 decompressor.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2026-FE65941, CLEANSTART-2026-JO59370, CLEANSTART-2026-PK52336, CLEANSTART-2026-PM70548, CLEANSTART-2026-TG86788, CLEANSTART-2026-VZ71675, CLEANSTART-2026-XX38187, DEBIAN-CVE-2026-106453, ECHO-711a-0c08-cc2a, GHSA-6cx8-rjf8-pr8g, MINI-2453-v42q-959g, MINI-2hxq-22m3-wjjg, MINI-3c6g-m8fq-x5p6, MINI-3qmr-j6rf-r76h, MINI-3rg7-78j4-qr3h, MINI-472r-xg85-cj4g, MINI-48p2-7jxw-phvh, MINI-579r-gvr3-prxh, MINI-5c4c-3x2x-r4jh, MINI-6322-5m8w-fxpc, MINI-65pw-wmhx-h7hq, MINI-6pr7-8p4x-xwq9, MINI-6xmg-qmhr-5p53, MINI-784q-vj4r-v3c5, MINI-7999-v342-q499, MINI-7x68-xfj5-frj2, MINI-825x-59vf-m45j, MINI-87ww-4h7m-vq4g, MINI-92wv-xfc7-f47q, MINI-fg5r-vw9r-hmr9, MINI-fph2-mmpq-pww4, MINI-gc7c-2wjg-2hff, MINI-hhxx-gqxr-w4q9, MINI-j988-8q72-655f, MINI-jmr3-6fm2-7pfc, MINI-m5xx-5g76-g9ph, MINI-mcm6-gjv9-7mmh, MINI-mf6w-6xg7-m9qp, MINI-p2qh-3w4c-92mg, MINI-p3m8-344r-vwwq, MINI-pwx5-hpqp-x8p9, MINI-q8r3-cf7w-mfx3, MINI-qf5c-r6gp-hff9, MINI-qp67-g4xw-9gwp, MINI-r39v-xp86-2xp3, MINI-r5gh-gvqc-9xf9, MINI-r9v7-89wr-jrc8, MINI-rmhj-89gw-3r4v, MINI-v67g-7m9m-64q4, MINI-v7f9-2h63-8hqg, MINI-vxgx-49rj-236g, MINI-w35j-jqhg-p8f8, MINI-w7qw-632m-hjjj, MINI-w8rc-v4rf-m2r8, MINI-wrqv-x264-gc6v, MINI-x5wg-vh9h-wxg3, UBUNTU-CVE-2026-106453

## What is CVE-2026-106453?

CVE-2026-106453 is a medium-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.2, LZ4DecompressorWithLength uses getDecompressedLength to trust the four-byte decompressed-length header before validating the compressed input, allowing a five-byte attacker-supplied input whose header declares a large output size to request up to approximately 2 GiB and exhaust the JVM heap. Convenience overloads backed by LZ4FastDecompressor or LZ4SafeDecompressor allocate the untrusted size, while overloads that write to a caller-provided destination buffer are not affected because the caller controls the destination size. This issue is fixed in version 1.11.2.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-106453?

4 open source packages ship an affected version, including at.yawk.lz4:lz4-java and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.2 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.2 |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |

## How do I fix CVE-2026-106453?

Upgrade at.yawk.lz4:lz4-java to 1.11.2 or later.

## Is CVE-2026-106453 being exploited?

There is no known exploitation of CVE-2026-106453 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106453 and fix it if it is affected.

What it is: CVE-2026-106453 is a medium-severity denial of service vulnerability in yawkat lz4-java, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106453 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.2
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.2
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106453/ (Markdown: https://insights.sbomify.com/CVE-2026-106453/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106453
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106453
- OSV: https://osv.dev/vulnerability/CVE-2026-106453

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106453/
Summaries are generated and may contain mistakes; the official description above is the record.
