{"answers":{"affected":"2 open source packages ship an affected version, including @backstage/plugin-proxy-backend. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-106456 in the wild and no public exploit code.","fix":"Upgrade @backstage/plugin-proxy-backend to 0.6.18 or later.","what":"CVE-2026-106456 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-106456 and fix it if it is affected.\n\nWhat it is: CVE-2026-106456 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-106456 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/plugin-proxy-backend (npm): affected from 0.5.0; fixed in 0.6.18\n- @backstage/plugin-proxy-backend (npm): affected from 0.5.0; fixed in 0.6.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-106456/ (Markdown: https://insights.sbomify.com/CVE-2026-106456/index.md)","id":"CVE-2026-106456","markdown":"https://insights.sbomify.com/CVE-2026-106456/index.md","name":"CVE-2026-106456","record":{"aliases":["GHSA-472h-9c5j-prrr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Backstage developer portal","requires_auth":"none","summary":"Unauthenticated users can bypass credential checks on nested proxy routes if parent paths allow public access, exposing upstream services.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"backstage","vendor":"linuxfoundation"},{"product":"backstage\\/plugin-proxy-backend","vendor":"linuxfoundation"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Backstage: Inconsistent credential enforcement for overlapping proxy routes","id":"CVE-2026-106456","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"linuxfoundation:backstage","products":["linuxfoundation:backstage"],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Backstage: Insufficient audience validation in the Cloudflare Access auth provider","id":"CVE-2026-106457"},"packages":[{"ecosystem":"npm","fixed":["0.6.18"],"introduced":["0.5.0"],"last_affected":[],"package":"@backstage/plugin-proxy-backend","purl":null,"source":"GHSA-472h-9c5j-prrr"},{"ecosystem":"npm","fixed":["0.6.18"],"introduced":["0.5.0"],"last_affected":[],"package":"@backstage/plugin-proxy-backend","purl":"pkg:npm/%40backstage/plugin-proxy-backend","source":"GHSA-472h-9c5j-prrr"}],"prev":{"headline":"Backstage: Improper validation of MkDocs plugin configuration in TechDocs","id":"CVE-2026-106455"},"products":["backstage","plugin-proxy-backend"],"published":"2026-10-06","related":[{"cvss_score":9.6,"headline":"Backstage: Sensitive information exposure in Scaffolder","id":"CVE-2026-106501","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":8.8,"headline":"Backstage: Improper validation of TechDocs MkDocs configuration","id":"CVE-2026-106558","kev_date_added":null,"published":"2026-10-07"},{"cvss_score":8.8,"headline":"Backstage: Improper input validation in TechDocs MkDocs configuration","id":"CVE-2026-88064","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":8.5,"headline":"Backstage: Improper input validation in Sentry scaffolder actions","id":"CVE-2026-106459","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":8.5,"headline":"Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions","id":"CVE-2026-106486","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":8.5,"headline":"Backstage: Improper task state validation in Scaffolder backend","id":"CVE-2026-106500","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":8.5,"headline":"Path Traversal in @backstage/plugin-scaffolder-backend","id":"CVE-2021-43783","kev_date_added":null,"published":"2021-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-07","vendors":["@backstage","backstage"]},"summary":"Unauthenticated users can bypass credential checks on nested proxy routes if parent paths allow public access, exposing upstream services.","url":"https://insights.sbomify.com/CVE-2026-106456/"}