# CVE-2026-106456: Backstage: Inconsistent credential enforcement for overlapping proxy routes

> Unauthenticated users can bypass credential checks on nested proxy routes if parent paths allow public access, exposing upstream services.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-472h-9c5j-prrr

## What is CVE-2026-106456?

CVE-2026-106456 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-106456?

2 open source packages ship an affected version, including @backstage/plugin-proxy-backend. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-proxy-backend` | npm | From 0.5.0 | 0.6.18 |
| `@backstage/plugin-proxy-backend` | npm | From 0.5.0 | 0.6.18 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Proxy-Backend.

## How do I fix CVE-2026-106456?

Upgrade @backstage/plugin-proxy-backend to 0.6.18 or later.

## Is CVE-2026-106456 being exploited?

There is no known exploitation of CVE-2026-106456 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106456 and fix it if it is affected.

What it is: CVE-2026-106456 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106456 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-proxy-backend (npm): affected from 0.5.0; fixed in 0.6.18
- @backstage/plugin-proxy-backend (npm): affected from 0.5.0; fixed in 0.6.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106456/ (Markdown: https://insights.sbomify.com/CVE-2026-106456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106456
- OSV: https://osv.dev/vulnerability/CVE-2026-106456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106456/
Summaries are generated and may contain mistakes; the official description above is the record.
