CVE-2026-106457 Backstage: Insufficient audience validation in the Cloudflare Access auth provider

Medium 6.8 Published Updated

Attackers with valid tokens for other Cloudflare Access apps can authenticate to Backstage if audience validation is not enforced upstream.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-106457?

CVE-2026-106457 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream. Cloudflare Access normally evaluates the protected application before forwarding requests. This issue is fixed in version 0.5.0.

Weakness: CWE-287

Which versions are affected by CVE-2026-106457?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend-module-cloudflare-access-provider. It affects 2 products.

PackageAffectedFixed in
@backstage/plugin-auth-backend-module-cloudflare-access-provider npmFrom 0.1.00.5.0
@backstage/plugin-auth-backend-module-cloudflare-access-provider npmFrom 0.1.00.5.0

Products include Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Auth-Backend-Module-Cloudflare-Access-Provider.

How do I fix CVE-2026-106457?

Upgrade @backstage/plugin-auth-backend-module-cloudflare-access-provider to 0.5.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-106457 being exploited?

There is no known exploitation of CVE-2026-106457 in the wild and no public exploit code.

All Linuxfoundation Backstage vulnerabilities

Sources

Also known as GHSA-q333-f498-w2x7.

Is CVE-2026-106457 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free