# CVE-2026-106457: Backstage: Insufficient audience validation in the Cloudflare Access auth provider

> Attackers with valid tokens for other Cloudflare Access apps can authenticate to Backstage if audience validation is not enforced upstream.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-q333-f498-w2x7

## What is CVE-2026-106457?

CVE-2026-106457 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream. Cloudflare Access normally evaluates the protected application before forwarding requests. This issue is fixed in version 0.5.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-106457?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend-module-cloudflare-access-provider. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-auth-backend-module-cloudflare-access-provider` | npm | From 0.1.0 | 0.5.0 |
| `@backstage/plugin-auth-backend-module-cloudflare-access-provider` | npm | From 0.1.0 | 0.5.0 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Auth-Backend-Module-Cloudflare-Access-Provider.

## How do I fix CVE-2026-106457?

Upgrade @backstage/plugin-auth-backend-module-cloudflare-access-provider to 0.5.0 or later.

## Is CVE-2026-106457 being exploited?

There is no known exploitation of CVE-2026-106457 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106457 and fix it if it is affected.

What it is: CVE-2026-106457 is a medium-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106457 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-auth-backend-module-cloudflare-access-provider (npm): affected from 0.1.0; fixed in 0.5.0
- @backstage/plugin-auth-backend-module-cloudflare-access-provider (npm): affected from 0.1.0; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106457/ (Markdown: https://insights.sbomify.com/CVE-2026-106457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106457
- OSV: https://osv.dev/vulnerability/CVE-2026-106457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106457/
Summaries are generated and may contain mistakes; the official description above is the record.
