# CVE-2026-106458: Backstage: Inconsistent repository filtering in Bitbucket Server catalog event updates

> Authenticated users can inject unauthorized repository locations into Backstage catalogs by exploiting inconsistent filtering in event-driven updates.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-c36c-cf6r-ghgj

## What is CVE-2026-106458?

CVE-2026-106458 is a medium-severity missing authorization vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. From 0.4.0 until 0.5.15, the @backstage/plugin-catalog-backend-module-bitbucket-server package is affected by inconsistent repository filtering in bitbucket server catalog event updates. Deployments using event-driven updates in the Bitbucket Server catalog provider may ingest catalog locations from repositories that are excluded by the provider's configured project, repository, or archived-repository filters. An authenticated Bitbucket Server user who can push to a filtered-out repository that remains readable by the configured Backstage integration can trigger a legitimate repository event. The affected event path may then add a Location for that repository even though scheduled discovery excludes it. This issue is fixed in version 0.5.15.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-106458?

2 open source packages ship an affected version, including @backstage/plugin-catalog-backend-module-bitbucket-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-catalog-backend-module-bitbucket-server` | npm | From 0.4.0 | 0.5.15 |
| `@backstage/plugin-catalog-backend-module-bitbucket-server` | npm | From 0.4.0 | 0.5.15 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Catalog-Backend-Module-Bitbucket-Server.

## How do I fix CVE-2026-106458?

Upgrade @backstage/plugin-catalog-backend-module-bitbucket-server to 0.5.15 or later.

## Is CVE-2026-106458 being exploited?

There is no known exploitation of CVE-2026-106458 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106458 and fix it if it is affected.

What it is: CVE-2026-106458 is a medium-severity missing authorization vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106458 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-catalog-backend-module-bitbucket-server (npm): affected from 0.4.0; fixed in 0.5.15
- @backstage/plugin-catalog-backend-module-bitbucket-server (npm): affected from 0.4.0; fixed in 0.5.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106458/ (Markdown: https://insights.sbomify.com/CVE-2026-106458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106458
- OSV: https://osv.dev/vulnerability/CVE-2026-106458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106458/
Summaries are generated and may contain mistakes; the official description above is the record.
