# CVE-2026-106462: Backstage: Scaffolder credential handling may allow unintended GitHub authentication fallback

> Authenticated users can bypass credential boundaries to perform GitHub operations with broader access than intended in Backstage scaffolder actions.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-29gx-h2m3-xw44

## What is CVE-2026-106462?

CVE-2026-106462 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 1.54.6, scaffolder source-control actions may not consistently enforce intended credential boundaries. An authenticated user could cause an affected action to fall back to broader integration credentials and perform operations with more access than intended. This issue is fixed in 1.54.6 when operators also enable scaffolder.requireScmUserCredentials after upgrading.

Weakness: CWE-863 (Incorrect Authorization), CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-106462?

12 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend, @backstage/plugin-scaffolder-backend-module-azure and @backstage/plugin-scaffolder-backend-module-bitbucket-cloud. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 4.1.0 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 4.1.0 |
| `@backstage/plugin-scaffolder-backend-module-azure` | npm | All versions | 0.2.25 |
| `@backstage/plugin-scaffolder-backend-module-azure` | npm | All versions | 0.2.25 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-cloud` | npm | All versions | 0.3.10 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-cloud` | npm | All versions | 0.3.10 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-server` | npm | All versions | 0.2.25 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-server` | npm | All versions | 0.2.25 |
| `@backstage/plugin-scaffolder-backend-module-github` | npm | All versions | 0.9.13 |
| `@backstage/plugin-scaffolder-backend-module-github` | npm | All versions | 0.9.13 |
| `@backstage/plugin-scaffolder-backend-module-gitlab` | npm | All versions | 0.11.10 |
| `@backstage/plugin-scaffolder-backend-module-gitlab` | npm | All versions | 0.11.10 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Azure, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Bitbucket-Cloud, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Bitbucket-Server, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Github, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Gitlab.

## How do I fix CVE-2026-106462?

Upgrade @backstage/plugin-scaffolder-backend to 4.1.0 or later.

## Is CVE-2026-106462 being exploited?

There is no known exploitation of CVE-2026-106462 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106462 and fix it if it is affected.

What it is: CVE-2026-106462 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106462 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 4.1.0
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 4.1.0
- @backstage/plugin-scaffolder-backend-module-azure (npm): affected all versions; fixed in 0.2.25
- @backstage/plugin-scaffolder-backend-module-azure (npm): affected all versions; fixed in 0.2.25
- @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (npm): affected all versions; fixed in 0.3.10
- @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (npm): affected all versions; fixed in 0.3.10
- @backstage/plugin-scaffolder-backend-module-bitbucket-server (npm): affected all versions; fixed in 0.2.25
- @backstage/plugin-scaffolder-backend-module-bitbucket-server (npm): affected all versions; fixed in 0.2.25
- @backstage/plugin-scaffolder-backend-module-github (npm): affected all versions; fixed in 0.9.13
- @backstage/plugin-scaffolder-backend-module-github (npm): affected all versions; fixed in 0.9.13
- @backstage/plugin-scaffolder-backend-module-gitlab (npm): affected all versions; fixed in 0.11.10
- @backstage/plugin-scaffolder-backend-module-gitlab (npm): affected all versions; fixed in 0.11.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106462/ (Markdown: https://insights.sbomify.com/CVE-2026-106462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106462
- OSV: https://osv.dev/vulnerability/CVE-2026-106462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106462/
Summaries are generated and may contain mistakes; the official description above is the record.
