# CVE-2026-106486: Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions

> Authenticated users can exploit improper filesystem validation in Bitbucket scaffolder actions to access or modify files outside the intended directory.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-g8rx-f7m5-7794

## What is CVE-2026-106486?

CVE-2026-106486 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.3.10 in @backstage/plugin-scaffolder-backend-module-bitbucket-cloud and 0.2.25 in @backstage/plugin-scaffolder-backend-module-bitbucket-server, the Bitbucket pull-request Scaffolder actions did not sufficiently validate filesystem paths. An authenticated user who can execute an eligible template and influence an allowed Bitbucket repository could affect paths outside the expected working area, potentially compromising backend confidentiality, integrity, or availability. This issue is fixed in @backstage/plugin-scaffolder-backend-module-bitbucket-cloud 0.3.10 and @backstage/plugin-scaffolder-backend-module-bitbucket-server 0.2.25.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106486?

4 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend-module-bitbucket-cloud and @backstage/plugin-scaffolder-backend-module-bitbucket-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-cloud` | npm | All versions | 0.3.10 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-cloud` | npm | All versions | 0.3.10 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-server` | npm | All versions | 0.2.25 |
| `@backstage/plugin-scaffolder-backend-module-bitbucket-server` | npm | All versions | 0.2.25 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Bitbucket-Cloud, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Bitbucket-Server.

## How do I fix CVE-2026-106486?

Upgrade @backstage/plugin-scaffolder-backend-module-bitbucket-cloud to 0.3.10 or later.

## Is CVE-2026-106486 being exploited?

There is no known exploitation of CVE-2026-106486 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106500](https://insights.sbomify.com/CVE-2026-106500/): Backstage: Improper task state validation in Scaffolder backend (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106486 and fix it if it is affected.

What it is: CVE-2026-106486 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106486 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (npm): affected all versions; fixed in 0.3.10
- @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (npm): affected all versions; fixed in 0.3.10
- @backstage/plugin-scaffolder-backend-module-bitbucket-server (npm): affected all versions; fixed in 0.2.25
- @backstage/plugin-scaffolder-backend-module-bitbucket-server (npm): affected all versions; fixed in 0.2.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106486/ (Markdown: https://insights.sbomify.com/CVE-2026-106486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106486
- OSV: https://osv.dev/vulnerability/CVE-2026-106486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106486/
Summaries are generated and may contain mistakes; the official description above is the record.
