# CVE-2026-106488: Backstage: Improper authentication in the OIDC provider

> Authenticated users can assume other identities via unverified emails in OIDC, gaining unauthorized access and permissions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-826h-28h9-65hg

## What is CVE-2026-106488?

CVE-2026-106488 is a high-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.4.20, the @backstage/plugin-auth-backend-module-oidc-provider package is affected by improper authentication in the oidc provider. Deployments using OIDC email-based identity resolution with a provider that permits unverified email addresses may allow an authenticated provider user to assume another catalog identity. This may grant access and permissions associated with that user. No direct availability impact is demonstrated. This issue is fixed in version 0.4.20.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-106488?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend-module-oidc-provider. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-auth-backend-module-oidc-provider` | npm | All versions | 0.4.20 |
| `@backstage/plugin-auth-backend-module-oidc-provider` | npm | All versions | 0.4.20 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Auth-Backend-Module-Oidc-Provider.

## How do I fix CVE-2026-106488?

Upgrade @backstage/plugin-auth-backend-module-oidc-provider to 0.4.20 or later.

## Is CVE-2026-106488 being exploited?

There is no known exploitation of CVE-2026-106488 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106488 and fix it if it is affected.

What it is: CVE-2026-106488 is a high-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106488 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-auth-backend-module-oidc-provider (npm): affected all versions; fixed in 0.4.20
- @backstage/plugin-auth-backend-module-oidc-provider (npm): affected all versions; fixed in 0.4.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106488/ (Markdown: https://insights.sbomify.com/CVE-2026-106488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106488
- OSV: https://osv.dev/vulnerability/CVE-2026-106488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106488/
Summaries are generated and may contain mistakes; the official description above is the record.
