# CVE-2026-106492: Backstage: Improper preservation of access restrictions during service credential delegation

> Attackers can bypass service credential access restrictions in Backstage to perform unauthorized write operations via plugin delegation paths.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-cq7v-rfgc-5c7v

## What is CVE-2026-106492?

CVE-2026-106492 is a high-severity vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.16.1 and 0.17.8, the @backstage/backend-defaults package is affected by improper preservation of access restrictions during service credential delegation. An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for. This issue is fixed in versions 0.16.1 and 0.17.8.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-106492?

2 open source packages ship an affected version, including @backstage/backend-defaults. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Backend-Defaults.

## How do I fix CVE-2026-106492?

Upgrade @backstage/backend-defaults to 0.17.8 or later.

## Is CVE-2026-106492 being exploited?

There is no known exploitation of CVE-2026-106492 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106492 and fix it if it is affected.

What it is: CVE-2026-106492 is a high-severity vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106492 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106492/ (Markdown: https://insights.sbomify.com/CVE-2026-106492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106492
- OSV: https://osv.dev/vulnerability/CVE-2026-106492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106492/
Summaries are generated and may contain mistakes; the official description above is the record.
