# CVE-2026-106493: Backstage: Cloud storage catalog locations may cross configured storage boundaries

> Attackers can read catalog descriptors from outside intended storage boundaries in Backstage cloud storage providers, exposing sensitive data.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-xvh9-35w9-42m4

## What is CVE-2026-106493?

CVE-2026-106493 is a low-severity path traversal vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 1.54.6, cloud storage catalog providers did not sufficiently validate object paths. A principal able to create or rename objects in a configured Azure Blob Storage or AWS S3 catalog source could cause catalog descriptors to be read from outside the intended storage boundary, limited to locations reachable with the backend's configured credentials. This issue is fixed in 1.54.6.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106493?

6 open source packages ship an affected version, including @backstage/backend-defaults, @backstage/plugin-catalog-backend-module-aws and @backstage/plugin-catalog-backend-module-azure. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |
| `@backstage/plugin-catalog-backend-module-aws` | npm | All versions | 0.4.27 |
| `@backstage/plugin-catalog-backend-module-aws` | npm | All versions | 0.4.27 |
| `@backstage/plugin-catalog-backend-module-azure` | npm | All versions | 0.3.21 |
| `@backstage/plugin-catalog-backend-module-azure` | npm | All versions | 0.3.21 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Backend-Defaults, Linuxfoundation Backstage\/Plugin-Catalog-Backend-Module-Aws, Linuxfoundation Backstage\/Plugin-Catalog-Backend-Module-Azure.

## How do I fix CVE-2026-106493?

Upgrade @backstage/backend-defaults to 0.17.8 or later.

## Is CVE-2026-106493 being exploited?

There is no known exploitation of CVE-2026-106493 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106493 and fix it if it is affected.

What it is: CVE-2026-106493 is a low-severity path traversal vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106493 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8
- @backstage/plugin-catalog-backend-module-aws (npm): affected all versions; fixed in 0.4.27
- @backstage/plugin-catalog-backend-module-aws (npm): affected all versions; fixed in 0.4.27
- @backstage/plugin-catalog-backend-module-azure (npm): affected all versions; fixed in 0.3.21
- @backstage/plugin-catalog-backend-module-azure (npm): affected all versions; fixed in 0.3.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106493/ (Markdown: https://insights.sbomify.com/CVE-2026-106493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106493
- OSV: https://osv.dev/vulnerability/CVE-2026-106493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106493/
Summaries are generated and may contain mistakes; the official description above is the record.
