# CVE-2026-106495: Backstage: Improper access control in backend action invocation

> Authenticated users can bypass operator-configured action exclusions in Backstage backend-defaults, invoking restricted actions despite existing downstream authorization checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-3xr5-8w6c-p5gw

## What is CVE-2026-106495?

CVE-2026-106495 is a medium-severity missing authorization vulnerability in @backstage backend-defaults, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.17.8, the @backstage/backend-defaults package is affected by improper access control in backend action invocation. An authenticated user could invoke actions that an operator had excluded through action configuration. Existing action permissions and downstream authorization remain enforced. This issue is fixed in version 0.17.8.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-106495?

2 open source packages ship an affected version, including @backstage/backend-defaults.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |
| `@backstage/backend-defaults` | npm | All versions | 0.17.8 |

## How do I fix CVE-2026-106495?

Upgrade @backstage/backend-defaults to 0.17.8 or later.

## Is CVE-2026-106495 being exploited?

There is no known exploitation of CVE-2026-106495 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106495 and fix it if it is affected.

What it is: CVE-2026-106495 is a medium-severity missing authorization vulnerability in @backstage backend-defaults, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106495 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.17.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106495/ (Markdown: https://insights.sbomify.com/CVE-2026-106495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106495
- OSV: https://osv.dev/vulnerability/CVE-2026-106495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106495/
Summaries are generated and may contain mistakes; the official description above is the record.
