CVE-2026-106498 Backstage: Improper URL validation in catalog entity placeholder resolution

High 7.7 Published Updated

Authenticated users can exploit improper URL validation in catalog placeholders to access unauthorized internal resources under specific configurations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-106498?

CVE-2026-106498 is a high-severity server-side request forgery vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

Weakness: CWE-918, CWE-863

Which versions are affected by CVE-2026-106498?

2 open source packages ship an affected version, including @backstage/plugin-catalog-backend. It affects 2 products.

PackageAffectedFixed in
@backstage/plugin-catalog-backend npmAll versions3.9.1
@backstage/plugin-catalog-backend npmAll versions3.9.1

Products include Linuxfoundation Backstage, Linuxfoundation Backstage Plugin-Catalog-Backend.

How do I fix CVE-2026-106498?

Upgrade @backstage/plugin-catalog-backend to 3.9.1 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-106498 being exploited?

There is no known exploitation of CVE-2026-106498 in the wild and no public exploit code.

All Linuxfoundation Backstage vulnerabilities

Sources

Also known as GHSA-qgvj-qcf8-xq73.

Is CVE-2026-106498 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free