# CVE-2026-106498: Backstage: Improper URL validation in catalog entity placeholder resolution

> Authenticated users can exploit improper URL validation in catalog placeholders to access unauthorized internal resources under specific configurations.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-qgvj-qcf8-xq73

## What is CVE-2026-106498?

CVE-2026-106498 is a high-severity server-side request forgery vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-106498?

2 open source packages ship an affected version, including @backstage/plugin-catalog-backend. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-catalog-backend` | npm | All versions | 3.9.1 |
| `@backstage/plugin-catalog-backend` | npm | All versions | 3.9.1 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage Plugin-Catalog-Backend.

## How do I fix CVE-2026-106498?

Upgrade @backstage/plugin-catalog-backend to 3.9.1 or later.

## Is CVE-2026-106498 being exploited?

There is no known exploitation of CVE-2026-106498 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106498 and fix it if it is affected.

What it is: CVE-2026-106498 is a high-severity server-side request forgery vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106498 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.1
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106498/ (Markdown: https://insights.sbomify.com/CVE-2026-106498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106498
- OSV: https://osv.dev/vulnerability/CVE-2026-106498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106498/
Summaries are generated and may contain mistakes; the official description above is the record.
