CVE-2026-106501 Backstage: Sensitive information exposure in Scaffolder
Authenticated users can view internal execution data of other users' Scaffolder tasks, potentially exposing external service credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-106501?
CVE-2026-106501 is a critical vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder. An authenticated Backstage user who can read another user's Scaffolder task may receive internal execution data. In deployments where that data contains credentials for an external service, this may permit disclosure and unauthorized changes in that external service. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.
Which versions are affected by CVE-2026-106501?
8 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@backstage/plugin-scaffolder-backend npm | All versions | 3.3.1 |
@backstage/plugin-scaffolder-backend npm | All versions | 3.3.1 |
@backstage/plugin-scaffolder-backend npm | From 3.4.0 | 3.4.1 |
@backstage/plugin-scaffolder-backend npm | From 3.4.0 | 3.4.1 |
@backstage/plugin-scaffolder-backend npm | From 4.0.0 | 4.0.3 |
@backstage/plugin-scaffolder-backend npm | From 4.0.0 | 4.0.3 |
2 more packages
@backstage/plugin-scaffolder-backend npm | From 4.0.4 | 4.1.0 |
@backstage/plugin-scaffolder-backend npm | From 4.0.4 | 4.1.0 |
Products include Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend.
How do I fix CVE-2026-106501?
Upgrade @backstage/plugin-scaffolder-backend to a fixed version for your release line: 3.3.1, 3.4.1, 4.0.3 or 4.1.0.
Is CVE-2026-106501 being exploited?
There is no known exploitation of CVE-2026-106501 in the wild and no public exploit code.
Other vulnerabilities in Linuxfoundation Backstage
- CVE-2026-106558 Backstage: Improper validation of TechDocs MkDocs configuration
- CVE-2026-88064 Backstage: Improper input validation in TechDocs MkDocs configuration
- CVE-2026-106459 Backstage: Improper input validation in Sentry scaffolder actions
- CVE-2026-106486 Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions
- CVE-2026-106500 Backstage: Improper task state validation in Scaffolder backend
Sources
Also known as GHSA-g2v8-7jhw-pp8p.