# CVE-2026-106501: Backstage: Sensitive information exposure in Scaffolder

> Authenticated users can view internal execution data of other users' Scaffolder tasks, potentially exposing external service credentials.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-g2v8-7jhw-pp8p

## What is CVE-2026-106501?

CVE-2026-106501 is a critical vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder. An authenticated Backstage user who can read another user's Scaffolder task may receive internal execution data. In deployments where that data contains credentials for an external service, this may permit disclosure and unauthorized changes in that external service. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-106501?

8 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 3.3.1 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 3.3.1 |
| `@backstage/plugin-scaffolder-backend` | npm | From 3.4.0 | 3.4.1 |
| `@backstage/plugin-scaffolder-backend` | npm | From 3.4.0 | 3.4.1 |
| `@backstage/plugin-scaffolder-backend` | npm | From 4.0.0 | 4.0.3 |
| `@backstage/plugin-scaffolder-backend` | npm | From 4.0.0 | 4.0.3 |
| `@backstage/plugin-scaffolder-backend` | npm | From 4.0.4 | 4.1.0 |
| `@backstage/plugin-scaffolder-backend` | npm | From 4.0.4 | 4.1.0 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend.

## How do I fix CVE-2026-106501?

Upgrade @backstage/plugin-scaffolder-backend to a fixed version for your release line: 3.3.1, 3.4.1, 4.0.3 or 4.1.0.

## Is CVE-2026-106501 being exploited?

There is no known exploitation of CVE-2026-106501 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)
- [CVE-2026-106500](https://insights.sbomify.com/CVE-2026-106500/): Backstage: Improper task state validation in Scaffolder backend (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106501 and fix it if it is affected.

What it is: CVE-2026-106501 is a critical vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106501 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 3.3.1
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 3.3.1
- @backstage/plugin-scaffolder-backend (npm): affected from 3.4.0; fixed in 3.4.1
- @backstage/plugin-scaffolder-backend (npm): affected from 3.4.0; fixed in 3.4.1
- @backstage/plugin-scaffolder-backend (npm): affected from 4.0.0; fixed in 4.0.3
- @backstage/plugin-scaffolder-backend (npm): affected from 4.0.0; fixed in 4.0.3
- @backstage/plugin-scaffolder-backend (npm): affected from 4.0.4; fixed in 4.1.0
- @backstage/plugin-scaffolder-backend (npm): affected from 4.0.4; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106501/ (Markdown: https://insights.sbomify.com/CVE-2026-106501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106501
- OSV: https://osv.dev/vulnerability/CVE-2026-106501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106501/
Summaries are generated and may contain mistakes; the official description above is the record.
