CVE-2026-106503 Backstage: Scaffolder action input authorization bypass
Authenticated users can bypass Scaffolder action restrictions to gain unauthorized access to repositories and source-control resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-106503?
CVE-2026-106503 is a high-severity authentication bypass vulnerability in Linuxfoundation Backstage, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by scaffolder action input authorization bypass. An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.
Which versions are affected by CVE-2026-106503?
8 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@backstage/plugin-scaffolder-backend npm | All versions | 3.3.1 |
@backstage/plugin-scaffolder-backend npm | All versions | 3.3.1 |
@backstage/plugin-scaffolder-backend npm | From 3.4.0 | 3.4.1 |
@backstage/plugin-scaffolder-backend npm | From 3.4.0 | 3.4.1 |
@backstage/plugin-scaffolder-backend npm | From 4.0.0 | 4.0.3 |
@backstage/plugin-scaffolder-backend npm | From 4.0.0 | 4.0.3 |
2 more packages
@backstage/plugin-scaffolder-backend npm | From 4.0.4 | 4.1.0 |
@backstage/plugin-scaffolder-backend npm | From 4.0.4 | 4.1.0 |
Products include Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend.
How do I fix CVE-2026-106503?
Upgrade @backstage/plugin-scaffolder-backend to a fixed version for your release line: 3.3.1, 3.4.1, 4.0.3 or 4.1.0.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-106503 being exploited?
There is no known exploitation of CVE-2026-106503 in the wild and no public exploit code.
Other vulnerabilities in Linuxfoundation Backstage
- CVE-2026-106501 Backstage: Sensitive information exposure in Scaffolder
- CVE-2026-106558 Backstage: Improper validation of TechDocs MkDocs configuration
- CVE-2026-88064 Backstage: Improper input validation in TechDocs MkDocs configuration
- CVE-2026-106459 Backstage: Improper input validation in Sentry scaffolder actions
- CVE-2026-106486 Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions
Sources
Also known as GHSA-hmp2-4m7g-22cv.