CVE-2026-106557 Backstage: Improper input validation in TechDocs Markdown extension configuration
Authenticated users can trigger TechDocs builds to access internal network resources or backend data due to improper input validation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-106557?
CVE-2026-106557 is a high-severity server-side request forgery vulnerability in @backstage backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backstage is an open framework for building developer portals. Prior to 1.14.6 and 1.15.4, the @backstage/plugin-techdocs-node package did not sufficiently validate TechDocs Markdown extension configuration. An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary, potentially exposing backend-host data or internal network resources. This issue is fixed in versions 1.14.6 and 1.15.4 when pymdown-extensions 10.21.3 or later is also used, normally through mkdocs-techdocs-core 1.7.0 or later.
Which versions are affected by CVE-2026-106557?
2 open source packages ship an affected version, including @backstage/plugin-techdocs-node.
| Package | Affected | Fixed in |
|---|---|---|
@backstage/plugin-techdocs-node npm | All versions | 1.15.4 |
@backstage/plugin-techdocs-node npm | All versions | 1.15.4 |
How do I fix CVE-2026-106557?
Upgrade @backstage/plugin-techdocs-node to 1.15.4 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-106557 being exploited?
There is no known exploitation of CVE-2026-106557 in the wild and no public exploit code.
Sources
Also known as GHSA-f7v3-xhm6-w245.