# CVE-2026-106557: Backstage: Improper input validation in TechDocs Markdown extension configuration

> Authenticated users can trigger TechDocs builds to access internal network resources or backend data due to improper input validation.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-f7v3-xhm6-w245

## What is CVE-2026-106557?

CVE-2026-106557 is a high-severity server-side request forgery vulnerability in @backstage backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 1.14.6 and 1.15.4, the @backstage/plugin-techdocs-node package did not sufficiently validate TechDocs Markdown extension configuration. An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary, potentially exposing backend-host data or internal network resources. This issue is fixed in versions 1.14.6 and 1.15.4 when pymdown-extensions 10.21.3 or later is also used, normally through mkdocs-techdocs-core 1.7.0 or later.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106557?

2 open source packages ship an affected version, including @backstage/plugin-techdocs-node.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.15.4 |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.15.4 |

## How do I fix CVE-2026-106557?

Upgrade @backstage/plugin-techdocs-node to 1.15.4 or later.

## Is CVE-2026-106557 being exploited?

There is no known exploitation of CVE-2026-106557 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106557 and fix it if it is affected.

What it is: CVE-2026-106557 is a high-severity server-side request forgery vulnerability in @backstage backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106557 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.15.4
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106557/ (Markdown: https://insights.sbomify.com/CVE-2026-106557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106557
- OSV: https://osv.dev/vulnerability/CVE-2026-106557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106557/
Summaries are generated and may contain mistakes; the official description above is the record.
