CVE-2026-106558 Backstage: Improper validation of TechDocs MkDocs configuration
An authenticated attacker can bypass TechDocs sanitization to execute arbitrary code via improper validation of MkDocs configuration.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-106558?
CVE-2026-106558 is a high-severity unsafe deserialization vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backstage is an open framework for building developer portals. Prior to 1.14.8, 1.15.6, and 2.0.1, the @backstage/plugin-techdocs-node package improperly validated mapping-style markdown_extensions configuration. An authenticated attacker who can register or influence an SCM-backed documentation source may bypass TechDocs sanitization and cause Python objects to be imported and instantiated in the generator runtime, leading to arbitrary code execution. Earlier fixes in versions 1.14.6 and 1.15.4 did not fully address the supported mapping representation of markdown_extensions. Impact is greatest when documentation generation runs with backend credentials, filesystem access, or internal network access. This issue is fixed in versions 1.14.8, 1.15.6, and 2.0.1.
Weakness: CWE-502
Which versions are affected by CVE-2026-106558?
2 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@backstage/plugin-techdocs-node npm | All versions | 1.15.4 |
@backstage/plugin-techdocs-node npm | All versions | 1.15.4 |
Products include Linuxfoundation Backstage, Linuxfoundation Backstage Plugin-Techdocs-Node.
How do I fix CVE-2026-106558?
Upgrade @backstage/plugin-techdocs-node to 1.15.4 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-106558 being exploited?
There is no known exploitation of CVE-2026-106558 in the wild and no public exploit code.
Other vulnerabilities in Linuxfoundation Backstage
- CVE-2026-106501 Backstage: Sensitive information exposure in Scaffolder
- CVE-2026-88064 Backstage: Improper input validation in TechDocs MkDocs configuration
- CVE-2026-106459 Backstage: Improper input validation in Sentry scaffolder actions
- CVE-2026-106486 Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions
- CVE-2026-106500 Backstage: Improper task state validation in Scaffolder backend
Sources
Also known as GHSA-qmw3-745m-w99g.