# CVE-2026-106558: Backstage: Improper validation of TechDocs MkDocs configuration

> An authenticated attacker can bypass TechDocs sanitization to execute arbitrary code via improper validation of MkDocs configuration.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 10 Oct 2026
- **Also known as:** GHSA-qmw3-745m-w99g

## What is CVE-2026-106558?

CVE-2026-106558 is a high-severity unsafe deserialization vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 1.14.8, 1.15.6, and 2.0.1, the @backstage/plugin-techdocs-node package improperly validated mapping-style markdown_extensions configuration. An authenticated attacker who can register or influence an SCM-backed documentation source may bypass TechDocs sanitization and cause Python objects to be imported and instantiated in the generator runtime, leading to arbitrary code execution. Earlier fixes in versions 1.14.6 and 1.15.4 did not fully address the supported mapping representation of markdown_extensions. Impact is greatest when documentation generation runs with backend credentials, filesystem access, or internal network access. This issue is fixed in versions 1.14.8, 1.15.6, and 2.0.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-106558?

2 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.15.4 |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.15.4 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage Plugin-Techdocs-Node.

## How do I fix CVE-2026-106558?

Upgrade @backstage/plugin-techdocs-node to 1.15.4 or later.

## Is CVE-2026-106558 being exploited?

There is no known exploitation of CVE-2026-106558 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)
- [CVE-2026-106500](https://insights.sbomify.com/CVE-2026-106500/): Backstage: Improper task state validation in Scaffolder backend (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106558 and fix it if it is affected.

What it is: CVE-2026-106558 is a high-severity unsafe deserialization vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106558 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.15.4
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106558/ (Markdown: https://insights.sbomify.com/CVE-2026-106558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106558
- OSV: https://osv.dev/vulnerability/CVE-2026-106558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106558/
Summaries are generated and may contain mistakes; the official description above is the record.
