# CVE-2026-106560: Backstage: Improper repository path validation in a Scaffolder backend module

> Authenticated users can write files outside the intended workspace via improper path validation in the Backstage Confluence-to-Markdown scaffolder module.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-2cmg-v53w-8xfp

## What is CVE-2026-106560?

CVE-2026-106560 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper repository path validation in a scaffolder backend module. An authenticated user who can execute an affected template and control its repository file location may cause generated content to be written outside the task workspace, within locations writable by the Backstage backend process. This issue is fixed in version 0.3.25.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-106560?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend-module-confluence-to-markdown. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend-module-confluence-to-markdown` | npm | All versions | 0.3.25 |
| `@backstage/plugin-scaffolder-backend-module-confluence-to-markdown` | npm | All versions | 0.3.25 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Scaffolder-Backend-Module-Confluence-to-Markdown.

## How do I fix CVE-2026-106560?

Upgrade @backstage/plugin-scaffolder-backend-module-confluence-to-markdown to 0.3.25 or later.

## Is CVE-2026-106560 being exploited?

There is no known exploitation of CVE-2026-106560 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106560 and fix it if it is affected.

What it is: CVE-2026-106560 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106560 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend-module-confluence-to-markdown (npm): affected all versions; fixed in 0.3.25
- @backstage/plugin-scaffolder-backend-module-confluence-to-markdown (npm): affected all versions; fixed in 0.3.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106560/ (Markdown: https://insights.sbomify.com/CVE-2026-106560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106560
- OSV: https://osv.dev/vulnerability/CVE-2026-106560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106560/
Summaries are generated and may contain mistakes; the official description above is the record.
