# CVE-2026-106561: Backstage: Sensitive information disclosure in Kubernetes resource queries

> Authenticated users can retrieve sensitive Kubernetes resource data that should be masked, exposing credentials and confidential material in connected clusters.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-p795-mqf2-36mf

## What is CVE-2026-106561?

CVE-2026-106561 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.21.9, the @backstage/plugin-kubernetes-backend package is affected by sensitive information disclosure in kubernetes resource queries. An authenticated user holding the standard Kubernetes resource read permission could retrieve sensitive values that the Kubernetes plugin is designed to mask, potentially exposing credentials and other confidential material held in the connected clusters. Exposure is limited to resources that the Backstage service account is permitted to read and that match the targeted catalog entity's namespace and label selector. Deployments whose cluster credentials do not grant read access to these resources are unaffected. This issue is fixed in version 0.21.9.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-106561?

2 open source packages ship an affected version, including @backstage/plugin-kubernetes-backend. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-kubernetes-backend` | npm | All versions | 0.21.9 |
| `@backstage/plugin-kubernetes-backend` | npm | All versions | 0.21.9 |

Products: Linuxfoundation Backstage, Linuxfoundation Backstage\/Plugin-Kubernetes-Backend.

## How do I fix CVE-2026-106561?

Upgrade @backstage/plugin-kubernetes-backend to 0.21.9 or later.

## Is CVE-2026-106561 being exploited?

There is no known exploitation of CVE-2026-106561 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106561 and fix it if it is affected.

What it is: CVE-2026-106561 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 7 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-106561 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-kubernetes-backend (npm): affected all versions; fixed in 0.21.9
- @backstage/plugin-kubernetes-backend (npm): affected all versions; fixed in 0.21.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106561/ (Markdown: https://insights.sbomify.com/CVE-2026-106561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106561
- OSV: https://osv.dev/vulnerability/CVE-2026-106561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106561/
Summaries are generated and may contain mistakes; the official description above is the record.
