CVE-2026-106577 ImageMagick: Code Injection in the postscript coders

Medium 5.3 Published Updated

Attackers can inject code into PostScript output via unescaped values in ImageMagick, potentially leading to arbitrary code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-106577?

CVE-2026-106577 is a medium-severity code injection vulnerability in Imagemagick Imagemagick, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, unescaped or untrimmed values can inject code into output generated by PostScript coders. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.

Weakness: CWE-94

Which versions are affected by CVE-2026-106577?

It affects 1 product.

Products include Imagemagick Imagemagick.

How do I fix CVE-2026-106577?

Upgrade to a fixed version.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-106577 being exploited?

There is no known exploitation of CVE-2026-106577 in the wild and no public exploit code.

All Imagemagick Imagemagick vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-106577, ECHO-7e7a-642b-3d93, MINI-xp54-7fg5-g3wx, UBUNTU-CVE-2026-106577.

Is CVE-2026-106577 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free