# CVE-2026-106577: ImageMagick: Code Injection in the postscript coders

> Attackers can inject code into PostScript output via unescaped values in ImageMagick, potentially leading to arbitrary code execution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-106577, ECHO-7e7a-642b-3d93, MINI-xp54-7fg5-g3wx, UBUNTU-CVE-2026-106577

## What is CVE-2026-106577?

CVE-2026-106577 is a medium-severity code injection vulnerability in Imagemagick Imagemagick, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, unescaped or untrimmed values can inject code into output generated by PostScript coders. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-106577?

It affects 1 product.


Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-106577?

Upgrade to a fixed version.

## Is CVE-2026-106577 being exploited?

There is no known exploitation of CVE-2026-106577 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-106577 and fix it if it is affected.

What it is: CVE-2026-106577 is a medium-severity code injection vulnerability in Imagemagick Imagemagick, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-106577 in the wild and no public exploit code.

Affected product: Imagemagick Imagemagick. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-106577/ (Markdown: https://insights.sbomify.com/CVE-2026-106577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-106577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-106577
- OSV: https://osv.dev/vulnerability/CVE-2026-106577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-106577/
Summaries are generated and may contain mistakes; the official description above is the record.
