# CVE-2026-10691: wonderwhy-er DesktopCommanderMCP start_search search-manager.ts redos

> Remote attackers can cause denial of service in DesktopCommanderMCP via inefficient regular expressions in the start_search function.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-r87g-78mx-3wg4

## What is CVE-2026-10691?

CVE-2026-10691 is a medium-severity denial of service vulnerability in wonderwhy-er DesktopCommanderMCP, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw has been discovered in wonderwhy-er DesktopCommanderMCP up to 0.2.38. This impacts an unknown function of the file src/search-manager.ts of the component start_search. Performing a manipulation of the argument SearchResult[] results in inefficient regular expression complexity. It is possible to initiate the attack remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.2.39 will fix this issue. The patch is named 4ce845f8749b6a159b57b38dcc3357f7222a8078. It is suggested to upgrade the affected component.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-10691?

2 open source packages ship an affected version, including @wonderwhy-er/desktop-commander.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@wonderwhy-er/desktop-commander` | npm | All versions | 0.2.39 |
| `@wonderwhy-er/desktop-commander` | npm | All versions | 0.2.39 |

## How do I fix CVE-2026-10691?

Upgrade @wonderwhy-er/desktop-commander to 0.2.39 or later.

## Is CVE-2026-10691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10691 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10691 and fix it if it is affected.

What it is: CVE-2026-10691 is a medium-severity denial of service vulnerability in wonderwhy-er DesktopCommanderMCP, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10691 exists.

Affected packages and fixed versions:
- @wonderwhy-er/desktop-commander (npm): affected all versions; fixed in 0.2.39
- @wonderwhy-er/desktop-commander (npm): affected all versions; fixed in 0.2.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10691/ (Markdown: https://insights.sbomify.com/CVE-2026-10691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10691
- OSV: https://osv.dev/vulnerability/CVE-2026-10691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10691/
Summaries are generated and may contain mistakes; the official description above is the record.
