{"answers":{"affected":"3 open source packages ship an affected version, including code-index-mcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10692 exists.","fix":"Upgrade code-index-mcp to 2.14.1 or later.","what":"CVE-2026-10692 is a medium-severity denial of service vulnerability in johnhuang316 code-index-mcp, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-10692 and fix it if it is affected.\n\nWhat it is: CVE-2026-10692 is a medium-severity denial of service vulnerability in johnhuang316 code-index-mcp, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10692 exists.\n\nAffected packages and fixed versions:\n- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1\n- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1\n- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10692/ (Markdown: https://insights.sbomify.com/CVE-2026-10692/index.md)","id":"CVE-2026-10692","markdown":"https://insights.sbomify.com/CVE-2026-10692/index.md","name":"CVE-2026-10692","record":{"aliases":["GHSA-647r-72hf-4vmh","PYSEC-2026-2421"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python MCP library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in code-index-mcp by submitting malicious regex patterns to the search_code_advanced function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function is_safe_regex_pattern of the component search_code_advanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"johnhuang316 code-index-mcp search_code_advanced is_safe_regex_pattern redos","id":"CVE-2026-10692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":8,"next":{"headline":"SourceCodester Online Boat Reservation System Administrative Endpoint improper authorization","id":"CVE-2026-10693"},"packages":[{"ecosystem":"PyPI","fixed":["2.14.1"],"introduced":["0"],"last_affected":[],"package":"code-index-mcp","purl":null,"source":"GHSA-647r-72hf-4vmh"},{"ecosystem":"PyPI","fixed":["2.14.1"],"introduced":["0"],"last_affected":[],"package":"code-index-mcp","purl":"pkg:pypi/code-index-mcp","source":"GHSA-647r-72hf-4vmh"},{"ecosystem":"PyPI","fixed":["2.14.1"],"introduced":["0"],"last_affected":[],"package":"code-index-mcp","purl":"pkg:pypi/code-index-mcp","source":"PYSEC-2026-2421"}],"prev":{"headline":"wonderwhy-er DesktopCommanderMCP start_search search-manager.ts redos","id":"CVE-2026-10691"},"products":["code-index-mcp"],"published":"2026-06-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-03","vendors":["johnhuang316"]},"summary":"Remote attackers can cause denial of service in code-index-mcp by submitting malicious regex patterns to the search_code_advanced function.","url":"https://insights.sbomify.com/CVE-2026-10692/"}