# CVE-2026-10692: johnhuang316 code-index-mcp search_code_advanced is_safe_regex_pattern redos

> Remote attackers can cause denial of service in code-index-mcp by submitting malicious regex patterns to the search_code_advanced function.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-647r-72hf-4vmh, PYSEC-2026-2421

## What is CVE-2026-10692?

CVE-2026-10692 is a medium-severity denial of service vulnerability in johnhuang316 code-index-mcp, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function is_safe_regex_pattern of the component search_code_advanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-10692?

3 open source packages ship an affected version, including code-index-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code-index-mcp` | PyPI | All versions | 2.14.1 |
| `code-index-mcp` | PyPI | All versions | 2.14.1 |
| `code-index-mcp` | PyPI | All versions | 2.14.1 |

## How do I fix CVE-2026-10692?

Upgrade code-index-mcp to 2.14.1 or later.

## Is CVE-2026-10692 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10692 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10692 and fix it if it is affected.

What it is: CVE-2026-10692 is a medium-severity denial of service vulnerability in johnhuang316 code-index-mcp, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10692 exists.

Affected packages and fixed versions:
- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1
- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1
- code-index-mcp (PyPI): affected all versions; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10692/ (Markdown: https://insights.sbomify.com/CVE-2026-10692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10692
- OSV: https://osv.dev/vulnerability/CVE-2026-10692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10692/
Summaries are generated and may contain mistakes; the official description above is the record.
