# CVE-2026-10721: Concrete CMS: PHP Object Injection via unserialize() calls

> Unauthenticated attackers can achieve arbitrary code execution in Concrete CMS by injecting malicious serialized payloads into the database.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-g82f-9pw7-773w

## What is CVE-2026-10721?

CVE-2026-10721 is a high-severity unsafe deserialization vulnerability in Concrete CMS, published on 10 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Concrete CMS below 9.5.2 is vulnerable to PHP Object Injection via unserialize() calls in the  in Permission, Cache, and Search components. An unauthenticated attacker may trigger arbitrary PHP object instantiation if a malicious serialized payload has been placed in the database. Thanks XananasX7 for reporting.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-10721?

2 open source packages ship an affected version, including concrete5/concrete5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.5.2 |
| `concrete5/concrete5` | Packagist | All versions | 9.5.2 |

## How do I fix CVE-2026-10721?

Upgrade concrete5/concrete5 to 9.5.2 or later.

## Is CVE-2026-10721 being exploited?

There is no known exploitation of CVE-2026-10721 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10721 and fix it if it is affected.

What it is: CVE-2026-10721 is a high-severity unsafe deserialization vulnerability in Concrete CMS, published on 10 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-10721 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.2
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10721/ (Markdown: https://insights.sbomify.com/CVE-2026-10721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10721
- OSV: https://osv.dev/vulnerability/CVE-2026-10721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10721/
Summaries are generated and may contain mistakes; the official description above is the record.
