# CVE-2026-10722: cilium ebpf LoadCollectionSpec/LoadCollectionSpecFromReader btf.go loadRawSpec integer overflow

> A local attacker can trigger an integer overflow in the Cilium eBPF library's BTF loading function, potentially causing a denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** AZL-89390, AZL-89393, CLEANSTART-2026-CI21288, CLEANSTART-2026-KZ38920, CLEANSTART-2026-LX85041, DEBIAN-CVE-2026-10722, ECHO-f040-5fb5-1b4a, GHSA-xhgw-qwwf-pg32, GO-2026-6238, MINI-2f9f-2pgg-jfx2, MINI-2j72-2mrh-485r, MINI-2pjm-68x3-9pp3, MINI-2v69-6xrx-6vcm, MINI-2v7g-8xgp-2h25, MINI-34m3-qgrr-5c7c, MINI-358g-mr9v-p23f, MINI-36v8-f5jp-j78f, MINI-39qm-4cxf-xjpr, MINI-3cr4-8jqh-5q4v, MINI-3rrq-c2hp-r65v, MINI-445p-39hr-4cjj, MINI-4587-q4hj-h4xm, MINI-45j3-vfpg-jjqq, MINI-4f5q-h3fw-rf6v, MINI-4mjg-x2ff-794g, MINI-4mp4-gggq-2f6p, MINI-4mq4-p743-4qv8, MINI-4xmc-c5hr-vj2p, MINI-54pp-hhq5-j5g2, MINI-574p-cx7j-xr7w, MINI-589q-pr3p-pj38, MINI-5gf5-vvg9-cf5x, MINI-5pxc-8735-q8q3, MINI-5qc3-mgq7-w7gr, MINI-5w5f-gw6x-xp29, MINI-5x5w-24gx-v59m, MINI-68c2-gh26-7wp2, MINI-69f4-qg6c-q52j, MINI-6g59-vv6r-fhjf, MINI-6g6v-r6rr-8pr4, MINI-6rw8-pfxm-f2jc, MINI-6v86-vgm5-7g8w, MINI-6w6h-g548-h3mf, MINI-75hm-f2f3-m8wr, MINI-7777-vmvm-xg29, MINI-867w-pfp7-6wmq, MINI-89w5-jw76-5xvw, MINI-8fjg-w338-88h7, MINI-8g6v-275g-j7g6, MINI-8jhr-93m6-7gw6, MINI-8xmc-r6g7-jrcw, MINI-99cp-6jr5-972f, MINI-9fvq-5p7r-vrfg, MINI-9w4v-xfjh-4qcp, MINI-9w6q-pmg9-682m, MINI-cq65-gh9x-r33j, MINI-cx4c-pxwp-9xwj, MINI-f7j4-533f-8px5, MINI-ff45-mfch-9pp7, MINI-ff8g-m9wp-f333, MINI-fvr3-53jv-qf6p, MINI-g43f-pxh7-3ghh, MINI-g9p9-cg49-x49q, MINI-gmj6-7fmw-mp64, MINI-grwg-4hv8-fgf5, MINI-gwx2-mvm5-2367, MINI-h3xq-6jrv-q3cq, MINI-j25q-r8g5-43hq, MINI-j28x-qcwv-pvxr, MINI-j2r5-794h-84g5, MINI-j2v7-765x-p3p7, MINI-j5m2-22x8-x83r, MINI-j6mm-64mh-4vx5, MINI-jc28-xgmv-453w, MINI-jgvj-6g77-mqjj, MINI-jj57-rc69-69c7, MINI-jwh3-f73v-vvmx, MINI-m2h3-c7vq-85cg, MINI-mgx7-p26j-xj75, MINI-mmm2-p783-97g9, MINI-p4vv-ffwc-5pw4, MINI-p5c6-r5hx-gc6c, MINI-p6q9-76c4-5pcf, MINI-pcx5-rm3v-hq8h, MINI-q9vm-hh4w-7pfx, MINI-qr88-w8xq-9c68, MINI-r2rh-5h4x-33p3, MINI-rhmr-53mx-xvhj, MINI-rppq-gfg6-rx8q, MINI-rqwr-93mg-8h8v, MINI-v2f4-qp7x-hwxj, MINI-vm2f-pfcm-prg3, MINI-vmc9-jj23-52r7, MINI-vrfc-6h9h-374j, MINI-w2x3-3gw9-2c5r, MINI-w53j-wc7c-45m9, MINI-w978-rxr3-mpfg, MINI-wc86-v833-wc2c, MINI-wg6v-qm56-59hj, MINI-wjh4-rjw8-24f4, MINI-wwxc-g58x-c8rq, MINI-x3xw-xrrq-g6gf, MINI-x4vh-mv24-g756, MINI-xf3v-qx4c-p2f5, MINI-xq76-hcf7-9m74, MINI-xvp3-pjg5-8487, MINI-xxwg-vw98-gmgf, SUSE-SU-2026:22946-1, SUSE-SU-2026:22954-1, SUSE-SU-2026:23234-1, UBUNTU-CVE-2026-10722, openSUSE-SU-2026:11165-1, openSUSE-SU-2026:11443-1, openSUSE-SU-2026:21442-1, openSUSE-SU-2026:21574-1

## What is CVE-2026-10722?

CVE-2026-10722 is a medium-severity vulnerability in cilium ebpf, published on 3 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in cilium ebpf up to 0.21.0. This affects the function loadRawSpec of the file btf/btf.go of the component LoadCollectionSpec/LoadCollectionSpecFromReader. Such manipulation of the argument offset leads to integer overflow. The attack can only be performed from a local environment. The exploit has been disclosed to the public and may be used. The name of the patch is 533dfc82fd228bfadf42ea7180c39de7d9af47fa. A patch should be applied to remediate this issue.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-189

## Which versions are affected by CVE-2026-10722?

3 open source packages ship an affected version, including github.com/cilium/ebpf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/ebpf` | Go | All versions | 0.22.0 |
| `github.com/cilium/ebpf` | Go | All versions | 0.22.0 |
| `github.com/cilium/ebpf` | Go | All versions | 0.22.0 |
| `alloy` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.17.1-160000.1.1 |
| `alloy` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.17.1-160000.1.1 |
| `amazon-ecs-init` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.106.0-160000.1.1 |
| `alloy` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.17.1-160000.1.1 |
| `alloy` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.17.1-160000.1.1 |
| `amazon-ecs-init` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.106.0-160000.1.1 |
| `alloy` | openSUSE:Leap 16.0 | All versions | 1.17.1-160000.1.1 |
| `amazon-ecs-init` | openSUSE:Leap 16.0 | All versions | 1.106.0-160000.1.1 |
| `alloy` | openSUSE:Tumbleweed | All versions | 1.17.1-1.1 |
| `amazon-ecs-init` | openSUSE:Tumbleweed | All versions | 1.106.0-1.1 |

Products: Cilium Ebpf.

## How do I fix CVE-2026-10722?

Upgrade github.com/cilium/ebpf to 0.22.0 or later.

## Is CVE-2026-10722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10722 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10722 and fix it if it is affected.

What it is: CVE-2026-10722 is a medium-severity vulnerability in cilium ebpf, published on 3 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10722 exists.

Affected packages and fixed versions:
- github.com/cilium/ebpf (Go): affected all versions; fixed in 0.22.0
- github.com/cilium/ebpf (Go): affected all versions; fixed in 0.22.0
- github.com/cilium/ebpf (Go): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10722/ (Markdown: https://insights.sbomify.com/CVE-2026-10722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10722
- OSV: https://osv.dev/vulnerability/CVE-2026-10722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10722/
Summaries are generated and may contain mistakes; the official description above is the record.
