# CVE-2026-107286: Pydantic AI: Concurrency-limited models can keep their slot when a streamed request ends early

> Attackers can cause denial of service in Pydantic AI by triggering early stream termination that leaks concurrency slots, blocking subsequent requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-6fqq-452j-qhrp, PYSEC-2026-4276, PYSEC-2026-4285

## What is CVE-2026-107286?

CVE-2026-107286 is a high-severity denial of service vulnerability in pydantic-ai, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 2.10.0 until 2.53.0, streamed requests made through ConcurrencyLimitedModel or limit_model_concurrency can retain shared concurrency slots because anyio.CapacityLimiter associates an acquired slot with the borrowing task while streaming cleanup can run in a different task. Early stream termination, cancellation, consumer exceptions, or complete stream_text() consumption with debounce_by=0.1 can therefore leave capacity occupied, eventually preventing later requests that share the long-lived limiter from proceeding and causing a denial of service. Agent-level max_concurrency and non-streaming model requests are not affected. This issue is fixed in version 2.53.0.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2026-107286?

6 open source packages ship an affected version, including pydantic-ai and pydantic-ai-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pydantic-ai` | PyPI | From 2.10.0 | 2.53.0 |
| `pydantic-ai` | PyPI | From 2.10.0 | 2.53.0 |
| `pydantic-ai` | PyPI | From 2.10.0 | 2.53.0 |
| `pydantic-ai-slim` | PyPI | From 2.10.0 | 2.53.0 |
| `pydantic-ai-slim` | PyPI | From 2.10.0 | 2.53.0 |
| `pydantic-ai-slim` | PyPI | From 2.10.0 | 2.53.0 |

Products: Pydantic Pydantic Ai.

## How do I fix CVE-2026-107286?

Upgrade pydantic-ai to 2.53.0 or later.

## Is CVE-2026-107286 being exploited?

There is no known exploitation of CVE-2026-107286 in the wild and no public exploit code.

## Other vulnerabilities in pydantic-ai

- [CVE-2026-25580](https://insights.sbomify.com/CVE-2026-25580/): Pydantic AI Affected by Server-Side Request Forgery (SSRF) in URL Download Handling (high 8.6)
- [CVE-2026-107295](https://insights.sbomify.com/CVE-2026-107295/): Pydantic AI Web chat UI (`Agent.to_web()`, `clai web`): a website visited by the developer can trigger agent runs and server-side tool execution on the local chat endpoint (high 7.6)
- [CVE-2026-25640](https://insights.sbomify.com/CVE-2026-25640/): Pydantic AI affected by Stored XSS via Path Traversal in Web UI CDN URL (high 7.1)
- [CVE-2026-107289](https://insights.sbomify.com/CVE-2026-107289/): Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv6 zone identifiers (medium 6.8)
- [CVE-2026-46678](https://insights.sbomify.com/CVE-2026-46678/): Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv4-mapped IPv6 (Incomplete fix of CVE-2026-25580) (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107286 and fix it if it is affected.

What it is: CVE-2026-107286 is a high-severity denial of service vulnerability in pydantic-ai, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107286 in the wild and no public exploit code.

Affected packages and fixed versions:
- pydantic-ai (PyPI): affected from 2.10.0; fixed in 2.53.0
- pydantic-ai (PyPI): affected from 2.10.0; fixed in 2.53.0
- pydantic-ai (PyPI): affected from 2.10.0; fixed in 2.53.0
- pydantic-ai-slim (PyPI): affected from 2.10.0; fixed in 2.53.0
- pydantic-ai-slim (PyPI): affected from 2.10.0; fixed in 2.53.0
- pydantic-ai-slim (PyPI): affected from 2.10.0; fixed in 2.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107286/ (Markdown: https://insights.sbomify.com/CVE-2026-107286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107286
- OSV: https://osv.dev/vulnerability/CVE-2026-107286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107286/
Summaries are generated and may contain mistakes; the official description above is the record.
