# CVE-2026-107296: msgpack5: Decoding negative int64 values mutates the input buffer

> Decoding negative int64 values in msgpack5 mutates the input buffer, causing silent data corruption for applications reusing the buffer.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** AZL-106854, GHSA-qw35-55vc-rhgj

## What is CVE-2026-107296?

CVE-2026-107296 is a low-severity vulnerability in mcollina msgpack5, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

msgpack5 is a msgpack v5 implementation for node.js and the browser. Prior to 6.1.0, decoding a negative signed 64-bit integer modifies the corresponding bytes in the caller-provided input buffer while computing the value. Applications that retain or reuse encoded input for integrity checks, logging, or later processing can observe silently corrupted data, while positive integers and other MessagePack value types are unaffected. This issue is fixed in version 6.1.0.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2026-107296?

2 open source packages ship an affected version, including msgpack5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `msgpack5` | npm | All versions | 6.1.0 |
| `msgpack5` | npm | All versions | 6.1.0 |

## How do I fix CVE-2026-107296?

Upgrade msgpack5 to 6.1.0 or later.

## Is CVE-2026-107296 being exploited?

There is no known exploitation of CVE-2026-107296 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107296 and fix it if it is affected.

What it is: CVE-2026-107296 is a low-severity vulnerability in mcollina msgpack5, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107296 in the wild and no public exploit code.

Affected packages and fixed versions:
- msgpack5 (npm): affected all versions; fixed in 6.1.0
- msgpack5 (npm): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107296/ (Markdown: https://insights.sbomify.com/CVE-2026-107296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107296
- OSV: https://osv.dev/vulnerability/CVE-2026-107296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107296/
Summaries are generated and may contain mistakes; the official description above is the record.
